Skip navigation
Fortkentdad
Currently Being Moderated

Organizer Disappears after launch

Mar 27, 2013 9:17 PM

Tags: #organizer #catalog_corruption

I can launch my PS Elements 10 Organizer and it opens, briefly, then after a few seconds just disappears.  When I open Task Manager and check my applications I can see it is still running.  I did discover that if I open PSE10's Editor and then click on the Organizer tab from within Editor, then the Organizer icon appears on my system tray and I can double click it and then it opens, and stays open.

 

I've figured out the the problem is with my catalog.  If I unselect my catalog in the catalog menu, and close it.  Then PSE Organizer opens OK.  I even tried rebuilding a new catalog (I only have about 47,000 images to load so it did take a while (like almost an hour) but then I was able to load the program and not have it disappear.  Trouble is that now all my work of cataloging my images, that is identifying who's who in the pictures (like that facial recognition system) and tag photos with locations and other tags, as well as rate them with a star system,   All that is gone.  I'd really don't want to lose all that work. 

 

I did try repair the catalog - it finds errors, and then starts the repair, then disappears.  Thought it might be working in the background, just not visible,  But if it did, the fix didn't help.  Also tried optimze, same story. 

 

Yes I tried the CTR-ALT-SHIFT while opening Editor - deleted the settings, ... no help.

 

A reinstall of PSE10 didn't help.

 

FYI - I'm running Windows 8 64bit and Windows 7 64 bit on a dual boot machine.  Does not matter whether I'm in Win 8 or Win 7 the problem is the same.  It is the same catalog.  I really didn't want two different catalog so have my catalog on my data drive (my Operating Systems are each on their own SSD).  I'm running 32 GB Ram, using an AMD A10 APU and HD6670 graphics card.  I am running a three screen array using AMD Eyefinity to control the screens as one large 4800x900 display.  I did discover that if I close PSE Editor and it was too big (spans all three screens) it won't open next time and I have to disable my Eyefinity array, open PSE Editor on one screen, close it and then when I re-enable the three screens it will open, just gotta remember not to close it when it spans the full display.

 

I did try the disabling the three monitor array and just using one monitor for PSE Organizer to see if that made any difference, that is not the problem. 

 

I fear my catalog is currupt beyond repair and that all my work cataloging is lost. 

 

Let me know if there is any way to recover, repair a catalog - or if I'm wrong in thinking that this is a catalog problem.

 

FKD

Fort Kent, AB

 
Replies

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points