Skip navigation
Currently Being Moderated

Still Images Are Blurry

Apr 1, 2013 9:42 AM

Tags: #slide_show #still_image #premiere_cs6 #blurry_images #blurry_video

Hi All,

I will start with saying that, I saw quit a lot of discussions on the net with the same issue.  However couldnt find the solution for it.


The Issue:

I am trying to create a stop-motion video using Adobe Premiere Pro CS6.

I am importing a bunch of still photos into my project.

When I drag&drop any image into the sequence it looks very blurry relatively to the original photo.

The same result after rendering and exporting the sequence.


Additional settings:

I also set to automatically fit the photo(s) to the sequence settings (Default scale to frame size).


Raw Meterial:

4288X2848 JPG.


I tried to resize the photos before importing but I get the same results


The target sequence:


60 FPS


I tried other sequence setting with no much luck.


My questions:

What am I doing wrong?

Why I see the video/images blurry?


Thanks for your time and effort.



Sample of "What I See".

Pay attention that the right side is blurry, that is the video preview pane. On the left is the original photo preview.

  • Currently Being Moderated
    Apr 1, 2013 1:23 PM   in reply to aaronc76

    Going from a 4K original down to SD resolution, this is what happens.

    Mark as:
  • Currently Being Moderated
    Apr 1, 2013 1:26 PM   in reply to aaronc76

    Take a look at the graphic in Reply # 1, in this thread:


    Though the thread was talking more about up-rezzing, IIRC, the graphic shows the differences, and when one down-rezzes to ~ 1/8 of the resolution, there will be a loss in quality, as well.


    Good luck,



    Mark as:
  • Currently Being Moderated
    Apr 1, 2013 9:05 PM   in reply to Bill Hunt

    Just out of curiosity, and it may have nothing to do with anything, but it might...


    Why are you using 60 frames per second but using a PAL sized frame? And are you sure it is not 60i instead of 60p? You might be throwing away have of the fields when you preview interlaced footage, which Premiere Pro might think you are using.


    Also, perhaps the problem is the interpretation of square pixels in the picture to rectangular pixels on the timeline.  Perhaps you would be better off making the change from square to rectangular in Photoshop instead of Premiere Pro.


    What is the final export going to be? DVD? Web Site? YouTube?


    What are your sequence settings?

    Mark as:
  • Currently Being Moderated
    Apr 1, 2013 9:15 PM   in reply to Steven L. Gotz



    I think that you meant that question, in your Reply for Aaronc, and not for me.


    If not, then I cannot answer, but think that Aaronc can, or hope so.



    Mark as:
  • Currently Being Moderated
    Apr 1, 2013 10:25 PM   in reply to Bill Hunt

    Yes, that's correct. I got in the habit of responding to the last post well before they started marking who the response was to exactly. Sorry about that.


    What about it Aaron?

    Mark as:
  • Currently Being Moderated
    Apr 2, 2013 5:33 AM   in reply to aaronc76

    Not resizing. I am suggesting that you change the PAR. The Pixel Aspect Ratio.



    I asked a bunch of questions in post #3. If you answer them we might have the solution.

    Mark as:
  • Currently Being Moderated
    Apr 2, 2013 5:06 PM   in reply to aaronc76

    So what the solution is ?


    There are only two I can think of.


    If you need SD resolution, live with it.


    If you want higher resolution, move to high definition (or higher, depending on your intended mode of delivery and display).

    Mark as:
  • Currently Being Moderated
    Apr 2, 2013 10:39 PM   in reply to aaronc76

    First of all, I stopped watching the video when it says a second has 60 milliseconds. That is not true. And it is not relevant.


    I can't tell if you live in Israel or were vacationing there. They do use PAL there, but I think you should probably forget about using PAL.


    Here is my suggestion. Use your 4288X2848 image to create your sequence. Limit yourself to 24 frames per second and you will have a lot less work to do.


    I think you are being tricked into seeing something the wrong way. When I open one of my images in the Source Monitor, it is usually set to "Fit". Change it to 100%.


    When I have one of my images in the Program monitor, it is usually set to "Fit". Change it to 100%. Try this out. Pick a picture with something nice and sharp in the exact center of the image. Compare both monitors.


    Here is a shot of my screen doing that. There is a file size limit here on the forums so you are only seeing a small part of both monitors. I don't see any blurring. Do you?



    Edit: You are probably going to have to cut the frame size down to export it - for now. Just cut each number in half after upping the quality and setting the frames per second back to 24.. One of these days you may end up going back and exporting again - when Premiere Pro catches up and lets you export H.264 at that size.

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points