Skip navigation
Currently Being Moderated

problem updating asset within template

Apr 1, 2013 3:43 PM

Tags: #template #update #asset

I'm a Dreamweaver 5.5 newbie on Win XP. I have assets setup for the repetitive material in the body of my pages. I created a template that contains these assets. I can create a new page with the template and everything works as expected. However, when I update an asset, save it and click update, the asset is updated, but the template and its associated pages don't change. Is this something I should be able to do, or am I unclear on the concept?

 

Thanks for any thoughts.

 
Replies
  • Currently Being Moderated
    Apr 1, 2013 6:23 PM   in reply to backpack45scb

    What happens when you open the Template and update the link to the revised Asset?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2013 4:23 AM   in reply to backpack45scb

    When you say "Asset" are you speaking of a Library item? In what way are you updating the asset? And why, when you update the asset, would you expect the template to change?

     

    We may need to see the code to answer your question. Can you post a link to a live page?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2013 9:03 AM   in reply to backpack45scb

    When I open the template and do Modify>Library>Update Current Page, I don't see the revised asset contents appear in the template.

     

    When you open the Template? Or a template child page? Can we see the code on the template page?

     

    It might be relevant, though, that when I created the template, I replied No to Update Links. I wasn't sure at the time, and didn't want DW to mess with the affiliate links I had on the page. I'm thinking now that I should have replied Yes.

     

    Yes, that's relevant and would explain why changes to the template do not propagate to any child page. This is not a usual selection for using templates.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2013 9:09 AM   in reply to backpack45scb

    Copy the code on the template page and paste it into a reply.  That'll tell us what's happening with the library item. The workflow that you describe is quite normal - combining library items with templates can be a very powerful tool.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2013 9:11 AM   in reply to MurraySummers

    However, let me also say that I can see no strong argument or real benefit for putting a library item into a non-editable region of a template. What is that going to do for you that simply having the library item's code in that same non-editable region (i.e., without the library item) would not do?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 3, 2013 11:13 AM   in reply to backpack45scb

    I assume it is telling me that assets are not allowed in the editable part of a template:

     

    Logical, but incorrect.  That's just normal markup for a Library item insertion point - they are given (usually) a straw-colored highlight. I see no troublesome code in that brief snippet.

     

    (Nested templates *and* library items - boy your pages are really pimped up!)

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 3, 2013 1:07 PM   in reply to backpack45scb

    There are indeed problems on this page.

     

    In DW, a search for "<div" produces 27 hits, while a search for "</div" produces 29 hits. Further, validator finds a number of errors. Before working further with this or any other page, you need to fix these errors, unfortunately! Because of the broken <div> structure, DW is not recognizing the Library item that is not properly updating changes.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points