Skip navigation
depocracy
Currently Being Moderated

Did Windows Restore, now Elements not working.

Apr 1, 2013 11:00 PM

Tags: #restore #system

I did a system restore and now Elements won't work.  I re installed the program from the disc and it still won't work.  It gives the error message the Elements has unexpectedly quit whenever I try to open the editor.  The program worked fine until the restore.  The restore point i choose was long after the original install and shouldn't have messed anything up.  When I originally installed Elements, I put it on my slave drive.  When I re insalled it, I put it on a larger drive.

 
Replies
  • Currently Being Moderated
    Apr 2, 2013 1:24 AM   in reply to depocracy

    Find the exact crash info:

     

    Working with your Operating System’s Tools

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 3, 2013 12:44 AM   in reply to depocracy

    Restore might have messed things up. Try re-installing Elements and then check.

     

    If you do not have the installers for the version of Elements you are using, try looking for the same here. http://prodesigntools.com/tag/ddl

     

    Make sure to backup your catalog first. http://helpx.adobe.com/photoshop-elements/kb/backup-restore-move-catal og-photoshop.html

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 3, 2013 12:45 AM   in reply to depocracy

    [Moved the discussion to Photoshop Elements forum]

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 3, 2013 10:57 PM   in reply to depocracy

    As said in crash reporter, there may be some issues with your NVIDIA display drive. Try updating/re-installing this driver.

     

    ~Andromeda

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points