Skip navigation
Currently Being Moderated

How can i get "show hyperlinks" to work?

Apr 2, 2013 7:16 AM

Tags: #cs6 #hyperlinks #show_hyperlinks

I have CS6 on a Mac, running 10.7.5.

 

My ID file has many hyperlinks, all work fine when exported to PDF. The problem is that i can't "see" the hyperlinks inside my ID file. I have turned ON "show hyperlinks" and turned ON "show hidden characters." I have "overprint preview" turned OFF.

 

I CAN see other types of hidden characters, like spaces, tabs, bookmarks, etc. but not hyperlinks. From what i understand, these should appear with a thin grey box around them (?).

 

What should i do?

 
Replies
  • Currently Being Moderated
    Apr 2, 2013 8:17 AM   in reply to kevino2

    If you haven't given your hyperlinks a visible appearance, the easiest way to see them is in the Story Editor (Edit > Edit in Story Editor).

     

    Hyperlink.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2013 10:35 AM   in reply to Steve Werner

    I think hyperlinks could be batch changed visible afterwards with this excellent tip from Indesignsecrets.com:

    http://indesignsecrets.com/batch-change-hyperlinks-across-a-whole-inde sign-document.php

     

    I always create character style called "hyperlinks" etc before I start making hyperlinks, then I make sure that I choose that style in style dropdown in New Hyperlink window. It´s usefull even if there´s no appearance for that style at the beginning. I can always edit the style settings afterwards if I want, like change the color of the hyperlink text or make a underline for it etc...

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2013 11:46 AM   in reply to kevino2

    Don't trash your prefs. Hyperlinks aren't hidden characters, but there is a setting in each hyperlink that affects visibility:

     

    linky.png

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2013 11:49 AM   in reply to kevino2

    You don't need to trash your prefs, but you may need to re-do your hyperlinks. In the Hyperlinks panel, double-click on one of your hyperlinks. That should open the Edit Hyperlink window. Near the bottom is "Appearance" and the first choice is "Type:" change it from Invisible Rectangle to Visible Rectangle. Now the "show hyperlinks" and "hide hyperlinks" will visibly do something.

     

    Ahh Joel you not only beat me, you included a screen shot. Good job!

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2013 11:49 AM   in reply to Joel Cherney

    Note that there are two different ways to affect hyperlink appearance here - in the "Character Style" dropdown and the "Appearance" area. It sounds like you need to be able to see them when you're working; if you turn on the "Visible Rectangle" it will be visible in PDF and, I think, in print as well.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2013 11:50 AM   in reply to FergyMac

    Posting collisions from helpful people - they're an InDesign U2U forum tradition

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points