Skip navigation
jhemby22
Currently Being Moderated

Adobe FMS 4.5 and Streaming to DVR and Live Not Working

Apr 2, 2013 6:40 AM

Tags: #dvrcast #live_dvr

Hello,

 

I am having some issues with streaming Live and DVR. I am fairly new to the FMS world, but not to the streaming media world.

 

I am using a FMS server on AWS, version 4.5. I have installed DVRcast on the server and created a test application. I am seeing no errors in the logs, all services are running properly. No errors when connecting to the serve via FMLE. Logged into the Admin Console, I see the connection. In the Adobe Flash Media Playback Setup player, it just buffers. I try to play the rtmp stream in another test player and get a security error. Any suggestions would be greatly appreciated.

 
Replies
  • Currently Being Moderated
    Jul 17, 2013 12:31 PM   in reply to jhemby22

    Also having the same problem.

     

    Have installed the applications and stream to the server using FMLE with the DVR Auto Record on and the server is receiving the stream.

     

     

    But there is no file being saved and when I try to connect with a RTMP player it failes to connect, the livedvr_client_test sample code gives back "Main.as : Not connected to FMS yet - Trying again ...."

     

    Normal LIVE streaming works, it is just the application. Followed the PDF to the letter.

     

    Any help with this would be great!

     

    Thank you.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2013 10:15 PM   in reply to jackogara

    Ah I set the output stream name to mp4:stream.f4v and it now works live and if I use FMLE it also records with the DVR option enabled.

     

    Is there a way to get FMS to auto record the stream? Or is there something I can put in the stream name to get it to do this?

     

    Thanks

     

     

    [edit]

     

    Also, I can only get it to play in live mode with the StrobeMediaPlayback, when in VOD mode it just buffers.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2013 3:01 AM   in reply to jackogara

    YAY I got this working and it workds great.

     

    Though FMLE is a tad crap for what I want. Would want to use FFMPEG on one of my servers not FMLE.

     

    I can do it but can't get the stream to auto DVR without FMLE.

     

    It also removes past recordings and starts again ,would like it to just carry on.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points