Skip navigation
magusat999
Currently Being Moderated

Photoshop CS6 3D Workaround for Windows

Apr 4, 2013 1:22 AM

Tags: #issue #3d #bug #fix #workaround #black_screen #photoshop_cs6 #graphic_processor

After much searching for a solition to the problem of Photoshop not displaying, well - anything - under Windows (I did this with Windows 7 32bit, Photoshop CS6 Extended 13.0.1.1) I stumbled upon a workaround that will solve the issue at least until Adobe gets around to fixing it. I have the bare minimum system, so this should work wonderfully for those of you with a more robust setup:

 

Windows 7 Ultimate 32bit / Windows 8 Pro 32bit dual boot

4 gigs ram installed

About 2 terabytes disk space (multiple SATA drives)

Asus GTX+ 9800 Dark Knight 512mb graphic card

Intel Core2Duo 2.83mhz processor

 

EDIT: The problem is related to what I wrote below - but there is more to it than that. Supposedly this started with a Microsoft update (KB2670838 Platform Update - to "prepare your PC for IE10). Unfortunately, some people - like myself, cannot roll back to before this update was applied. Barring re-installing Windows, the other alternative is to turn off desktop compositing completely, or turn off Aero Glass. I am adding this because Photoshop was not the only application affected - anything using OpenGL is broken with this update! To turn off desktop compositing, either use a non-aero theme, or go to you systems propeties->performance tab and check off "Enable Desktop Compositing" - which will effectively turn off Aero Glass, but you will still have the other functions.  i wonder if Windows 8 has this problem as well?

 

Below is the original fix - which really doesn't fix the problem:

The solution is simple. Turn off desktop compositing for Photoshop ONLY. Either go to the link or go to the Photoshop.exe, right click, choose "Properties", then choose the "Compatibility" tab; then check Disable desktop compositing". This will disable Aero Glass ONLY when you open Photoshop - and lets face it, do we really need Aero Glass that bad? I think not. So as long as Photoshop is open your theme will be basic, when you close it it will automatically switch to Aero Glass and be al pretty again (well actually basic doesn't look THAT bad, but Aero is definitely cuter). With this workaround I am able to use the advanced option under "Graphic Processor Settings".

 

It works perfectly for me, with a minimal of inconvenience. If it works for everyone else then there's a bug here. I want credit and free Adobe products  (all of them) for life as payment! Notice I didn't "lol"? I'm not kidding!

 

Message was edited by: magusat999

 

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points