Skip navigation
Currently Being Moderated

Alien Skin Eye Candy 7 incompatible with Fireworks - when will this be fixed?

Apr 5, 2013 10:18 AM

Tags: #cs4 #problem #fireworks #skin #eye #incompatible #alien #candy

Alien Skin Eye Candy 6 worked fine with my Fireworks CS4. Then Alien Skin updated me to Eye Candy 7. While Eye Candy pops up and looks beautiful, even showcasing the effects within the screen, once I hit "OK", it crashes. I already complained to Alien Skin but they  say it is an Adobe issues. I uninstalled Eye Candy and reinstalled it as 32-bit only in the 32-bit version of Photoshop CS4, and again it works fine in Photoshop and looks great in Fireworks, once I hit "OK" it crashes again. My boss is now pissed because basically the effects are not usable except in Photoshop, and we use primarily Fireworks. What will be done about this? The Alien Skin site says this: "I completely understand your disappointment with the lack of Fireworks support. Due to the multiple changes made by Adobe, it has become prohibitively difficult to maintain Fireworks compatibility. For this reason we had to drop support for this program." There are many people complaining about this but what is the solution? I cannot randomly start using Photoshop esp when most of my files are in PNG format, and right now it is just wasted money and extremely frustrating.

 
Replies
  • Currently Being Moderated
    Apr 5, 2013 3:23 PM   in reply to stargirl

    If anyone knew what to do here—or had a little bit of clout to make something happen on the Fireworks side—you'd think it would be a major plug-in manufacturer (Alien Skin). From your post, I can't quite tell if you're still on CS4 or not. If you are, then it sounds like the practical solution would be to go back to Eye Candy 6.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2013 4:09 PM   in reply to stargirl

    My name is Robert, and I handle all technical support for Alien Skin. The main problem is that Fireworks still uses the Carbon API in the programming of the software. Newer plug-ins on the Mac use the Cocoa API, which allows full native support on the Mac. The main weakness of the Carbon API is that it's only 32bit, which is why Fireworks is still a 32bit application. Since Eye Candy contains the latest Cocoa API, compatibility is lost. So I guess it's not so much the changes by Adobe, as much as it is that Fireworks still uses the older Carbon API, while Eye Candy 7 uses the newer Cocoa API. I hope that explains it a little better.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 6, 2013 12:03 PM   in reply to Robert Lounsberry

    Robert, thanks so much for your post! It's helpful and informative. In fact, this might be good info to add to your company's website if there's any information there regarding Fireworks and compatibility with Eye Candy.

     

    Hopefully, you can help Stargirl restore to Eye Candy 6?

     

    The upshot of all this is that it's an issue that will never be fixed by Adobe for CS4, CS5, or CS6, as it would require rewriting the entire software, something they've deliberately chosen not to do. And there's little reason to think it would happen in a future version of Fireworks either, if in fact any more versions are ever released. Given that Adobe has chosen not to invest in Fireworks and upgrade it to a contemporary MacOS standard, I think it's understandable that a plug-in manufacturer like Alien Skin would follow suit and drop support, for both financial and creative reasons.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2013 10:12 AM   in reply to stargirl

    When I responded to your initial forum post on the Adobe forums, I was not 100% accurate. Eye Candy 7 does support the 32-bit Carbon API. Fireworks and Elements are both Carbon apps. However plug-in support for Fireworks is not near as good as the plug-in support for Elements. The plug-in API in Fireworks needs to be updated and improved before Fireworks will work with Eye Candy 7.

     

    I completely understand your frustration, and if you would like a refund, I would be more than happy to process it for you. Just email me at Support@alienskin.com. There, I can process your request. Again, I apologize for the trouble, and wish there was more we could do to resolve this issue for you.

     

    In regards to Eye Candy 6, If you submit a support ticket as mentioned above,  and I will do everything I can to get you up and running in Fireworks with Eye Candy 6.

     

    Question: Are you running Windows or Mac?

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points