Skip navigation
ChrissWE
Currently Being Moderated

Problem importing some .MOV files into Premiere Elements 11

Apr 6, 2013 4:14 AM

Tags: #premiere_elements_11 #premiere_elements11

Hello,

 

I am trying to import film footage into Premiere Elements 11 and am coming across a rather confusing problem. All of the footage is in .mov format and all of it was taken on the same device on the same day with the same settings.

 

When I try to import the footage, some files import ok, others will not import at all and I get a message saying 'The importer reported a generic error'. It seems very odd to me that some .MOV files are OK and others are not.

 

This same footage can easily be imported into Premiere Elements 10 and into Windows Movie Maker - which makes me think the issue is with Premiere Elements 11.

 

Does anyone have any ideas on this?

 

Thanks

 
Replies
  • Currently Being Moderated
    Apr 6, 2013 5:36 AM   in reply to ChrissWE

    What model of camcorder is your video coming from and what format and resolution is it? Did you use Premiere Elements to get the video from the camcorder to your computer?

     

    Have you ensured you have the latest version of Quicktime installed on your computer?

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points