Skip navigation
Currently Being Moderated

Spell Check Not Working on some Styles

Apr 8, 2013 10:48 AM

Tags: #styles #spelling

Hi everyone,

My spell check is being very weird. It is working in some sections of my document, but in others it's not. Basically I misspelled words on purpose and I get no red underline and it just ignores it in the spell check. Quite frightening. Is there some way that I maybe selected "No language" on accident for this style, or is my document corrupted?

 

Thanks for any help,

Paulette

 
Replies
  • Currently Being Moderated
    Apr 8, 2013 11:18 AM   in reply to PauletteP2

    Are you using a different language font in your text frames? Have you turned on the Dynamic spelling feature.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2013 12:26 PM   in reply to PauletteP2

    Check those paragraph styles to ensure that a style is selected.

     

    Dynamic spelling will put a red underline any words that are considered incorrectly spelt, you can go to the Edit>Preferences and Spelling to see what the other colours mean.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2013 12:34 PM   in reply to PauletteP2

    You should also verify that you really HAVE applied the correct language to the misspelled words (put your cursor in them and check the language assigned in the character panel), and then you may also be running afoul of a possible alternate spelling -- note Eugene's UK usage of "spelt," which also happens to be a perfectly legitmate word that is the name of a variety of wheat, so it probably would not be flagged in any variety of English. Same for color/colour.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2013 1:00 PM   in reply to Peter Spier

    Peter Spier wrote:

     

    -- note Eugene's UK usage of "spelt,"

    *cough* Irish *cough* *cough*

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2013 1:03 PM   in reply to PauletteP2

    It's possible that certain words were added to your Ignore List

     

    If you go to Edit>Spelling>Dictionary

     

    Check under Ignored and under Removed words

     

    This might be housing certain words that the spell check will ignore

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2013 1:03 PM   in reply to Eugene Tyson

    Just because the style uses a particular language is not an assurance that the language was not changed by either a character style or a local override. Check the actual text.

     

    And what are some of the words that are not being caught?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2013 1:08 PM   in reply to Eugene Tyson

    Eugene Tyson wrote:

     

    Peter Spier wrote:

     

    -- note Eugene's UK usage of "spelt,"

    *cough* Irish *cough* *cough*

    Well, I know you're Irish, but I don't see an Irish dictionary in ID, so I maybe made a bad presumption, and it's backed up, at least partially by http://www.merriam-webster.com/dictionary/spelt.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2013 1:32 PM   in reply to Peter Spier

    Ha yes I know there's a lot of Irish people and we're ancestors to a lot of United States folks, sadly we are forgotten on software installations

     

     

    I agree with Peter - you have to check all the Style for Grep Styles, Nested Styles, and all the Character styles etc. for something that is triggering the spelling errors

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2013 2:03 PM   in reply to PauletteP2

    Place your cursor in a word that you know is misspelled and is not being flagged. Open the Character (not Character Styles) panel. If Language is not showing at the bottom of that panel, go to the little dropdown in the upper-right corner of the panel and select Show Options. You'll see the language that's applied to that piece of text. As mentioned above, that could be applied via a paragraph or character style, a GREP or nested style within the applied paragraph style, or it could be a manual override.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2013 2:30 PM   in reply to PauletteP2

    Is it possible that some words were somehow set to "ignore"? Go under Edit > Spelling > Dictionary and under Dictionary List, select Ignored Words. Do "ttraining" or any of your other misspelled-but-not-flagged words show up there?

     

    If not, it might be time to trash your prefs and see if that fixes it.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 10, 2013 2:41 PM   in reply to PauletteP2

    Have you tried exporting it to IDML? That'll sometimes clear out random bugginess.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points