Skip navigation
Currently Being Moderated

Indesign cs6, export interactive pdf

Apr 9, 2013 8:51 AM

Tags: #pdf #export #buttons #layers #cs6

When i export my interactive document to pdf, the result is not working well. All the roll over buttons are blinking when the mouse cursor point on it. also i have problem with layers. the appearance of layers is not as same as file, so some images go under other.

I have no problem in preview and it works well in preview but when i export to pdf the result is catastrophic. 

Is there anyone have a same problem? Or anyone know what i am doing wrong?

 
Replies
  • Currently Being Moderated
    Apr 9, 2013 8:51 AM   in reply to amirthabib

    Are you viewing the PDF in Acrobat, reader, or some other viewer?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 9, 2013 8:58 AM   in reply to amirthabib

    I'm afraid I have no clue. Sorry.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 9, 2013 9:57 AM   in reply to Peter Spier

    Any interactivity (e.g., buttons) always appear above anything on the page. That's just the way PDF works.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 9, 2013 11:28 AM   in reply to amirthabib

    You're probably going to need to upload some screen captures to convey what you're experiencing. I don't recall layers being rearranged in the process of exporting an interactive PDF file.

     
    |
    Mark as:
  • Currently Being Moderated
    May 14, 2013 11:39 AM   in reply to amirthabib

    Hi,

     

    Did you ever find out how to fix this?  The same thing is happening to me.  I have a InDesign CS6 file with buttons that trigger animation.  It works great in preview and if I export to swf/html, but some elements (text and buttons that should be displayed) are missing when I export to the Interactive PDF.

     
    |
    Mark as:
  • Currently Being Moderated
    May 15, 2013 11:06 AM   in reply to Steve Werner

    I am having the same problem. Here are my screenshots. In Acrbat 10, in the layers pane, the layers names show up correctly, but in the actual graphics of the PDF, the layers are displayed in the reverse order.

     

    Screen Shot 2013-05-15 at 10.54.01 AM.png

    Screen Shot 2013-05-15 at 10.54.09 AM.png

     

    Screen Shot 2013-05-15 at 10.58.16 AM.png

     
    |
    Mark as:
  • Currently Being Moderated
    May 21, 2013 12:12 PM   in reply to amirthabib

    No answer for you, but the same thing is happening for me! Mine is like a map with pop-up captions on it. The captions (which are hidden-until-triggered, actionless buttons) are on a layer ABOVE the marker buttons in InDesign, but Acrobat still displays the markers above the captions. I even tried removing all of the actions from the buttons in InDesign and adding them in Acrobat, but it still didn't work. Here's a screenshot from Acrobat of the caption showing up behind the orange markers instead of on top of them:

    Screenshot.jpg

     

    Also, you can see that the corner of the caption is disabling the rollover state on the marker - it should be covering up that little orange piece. What is going on!?!

     
    |
    Mark as:
  • Currently Being Moderated
    May 21, 2013 12:16 PM   in reply to HDRKarijo22

    Are you trying to put static content above interactive content? I'm not

    an expert in interactive PDF by any means, but I don't think that's

    going to work.

     

    Hopefully one of the PDF gurus will stop by and be able to confirm that.

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    May 21, 2013 12:20 PM   in reply to HDRKarijo22

    It seems that for interactive elements, the stacking order is determined by the order in which the objects are converted to buttons. Try removing not just the actions, but turning them back into objects. Or, convert them into buttons in the oppsite order than you did the first time. It's maddening, but it should work. Apparently, button creation order trumps actual stacking order. Weird!

     
    |
    Mark as:
  • Currently Being Moderated
    May 21, 2013 12:59 PM   in reply to Bob Levine

    The captions are buttons too (just with no actions on them), so I was hoping it would treat them as interactive content, but maybe it doesn't! Maybe I will try adding an  action to them to see if that helps. If not, I'll try the re-stacking idea, but that will take a long time since I have tons of them! Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    May 21, 2013 1:51 PM   in reply to Document Geek

    YAY!! It was the stacking order! And that seems to have solved the rollover transparency issue too. I will just have to undo/redo all of them now, but I'm so glad there's a solution. Thanks so much!! I will definitely remember that for the next project.

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2013 9:05 AM   in reply to HDRKarijo22

    It turns out there are a few workarounds to solving the stacking order issue: copy and pasting, setting tab order in InDesign, or setting tab order in Acrobat. All the soltutions can be found here: http://indesignsecrets.com/stacking-order-bug-exporting-interactive-pd f.php.

     

    Be sure to read through the comments to get all the different solutions.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points