Skip navigation
Currently Being Moderated

Text of title is thinner with enabled mercury engine

Apr 16, 2013 2:41 PM

Premiere CS5.5

gtx560

Font Arial

Here is pictures.

With mercury enabled

http://savepic.org/3355012.jpg

 

With mercury disabled

http://savepic.org/3342724.jpg

 

How to remove this issue?

Thank You!

 
Replies
  • Currently Being Moderated
    Apr 16, 2013 8:55 PM   in reply to Malcev.Z

    Remove the black underneath.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 16, 2013 11:37 PM   in reply to Malcev.Z

    I saved both of those pictures and compared them in Photoshop. I do see a difference, but it is in the color of the shadow, not in the actual thickness of the font.

     

    Since you didn't add a shadow, I have to assume that it is caused by the "Fit" setting of the Program Monitor. Try it again with the image set at 100% instead.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:30 AM   in reply to Malcev.Z

    OK. I have duplicated the problem.

     

    I suppose the question is "why is this happening?". The exports from both settings are identical, and are the same as the preview that uses the Mercury hardware (CUDA) acceleration. Therefore, the previews for the Mercury acceleration are OK but the software only option is faulty in some way. I will have to leave this for someone more experienced with the Mercury Engine. But there is a problem that can probably be fixed eventually. I hope.

     

    I suppose it has something to do with the way that Premiere Pro renders previews. I tried using the highest quality previews I could but there is still a difference.

     

    If we can get an Adobe Engineer to reply, then I will skip the Bug Report if they provide a sufficiently good reason, or change in settings. Otherwise, this is a bug that needs to be fixed as far as I can tell.

     

    Todd? Kevin? Bueller? Bueller?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 8:03 AM   in reply to Steven L. Gotz

    I suppose the question is "why is this happening?".

     

    Linear Light Processing using by GPU acceleration, I presume.

     

    Removing the black underneath seems to solve it.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 4:46 PM   in reply to Jim Simon

    Jim,

     

    I did my test with text over sand. Here are my test files:

     

    This first one is a screen capture of a small area of the title over sand. Mercury Engine is using hardware.

     

    capture with CUDA.PNG

    This second one is a screen capture while the Mercury Engine is set to use software only.

     

    capture without CUDA.PNG

    If you put them both in Photoshop or Fireworks and switch back and forth between the tabs you can easily see the difference..

     

    It is only the preview that is a problem. The exports both look like the first one, with and without hardware in use. It is just the preview when using software only that is a problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 5:03 PM   in reply to Steven L. Gotz

    The difference is shown here:

    CUDA_01.png

    For this image, I added the Layer from one Image to the other, then changed the Blending Mode to Difference. To see that difference more clearly, I then added a Threshold Adjustment Layer.

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 6:38 PM   in reply to Bill Hunt

    Wow! Cool. Nice job.

     

    Now, is there a particular setting for preview files that will counteract this effect, or is a bug report required? That's what we need to know.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:05 PM   in reply to Malcev.Z

    If You mean replacing black video on video1 with for example solid white - it does not help.

     

    No, I just mean put nothing underneath the title.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:06 PM   in reply to Steven L. Gotz

    is there a particular setting for preview files that will counteract this effect

     

    Yes.  Remove any black underneath.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:10 PM   in reply to Jim Simon

    OK, now you have me confused Jim.

     

    I have no idea what you mean.

     

    Black letters have to have something under them or there will just be a black frame.

     

    Please ellucidate.

     

    Edit: Or are you saying the background has to be white (no black)?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:10 PM   in reply to Steven L. Gotz

    Steven,

     

    I do not know of a way to counteract this. I am only reporting on the "difference."

     

    Sorry, but I think that it's at least a "glitch," and probably a Bug.

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:12 PM   in reply to Bill Hunt

    I was hoping to have Kevin chime in. If he doesn't  then I will put in the report.

     

    Edit: I keep thinking that this would be easier if we just got on a conference call. You know?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:12 PM   in reply to Steven L. Gotz

    Steven,

     

    I think that Jim means a Color Matte, that is white, but maybe I am missing his suggestion?

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:13 PM   in reply to Steven L. Gotz

    Well, most titles are white, and the habit is to put a black clip underneath it in the sequence.  Titles seem to work fine over video with GPU on, but they get weird when you put that black (or other matte) clip under them.

     

    The OP has something under the title in his sequence.  I'm saying get rid of that, and the problem should go away.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:16 PM   in reply to Bill Hunt

    I put mine on sand. That is pretty neutral. Samples indicate

     

    R153 G153 B102 and R153 G102 B102. Those hover around the middle and seem fairly bland to me. I don't have much in the way of black under mine and I see the problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:18 PM   in reply to Steven L. Gotz

    Well, apparently it applies to more than just the mattes.  But for video, it seems to work fine.

     

    What I'm saying is, don't put anything under a title except video.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:26 PM   in reply to Jim Simon

    I have proven that the export is fine, but the preview is very misleading. I can see where it would cause a problem with titles that had to be specifically placed in an exact position.

     

    Try it for yourself. If you can find a way to preview a standard font the same way both with and without the Mercury hardware acceleration, please explain your steps.

     

    I used these settings for my test. It is one of my new standard presets for obvious reasons.

     

    Capture.PNG

     

    Edit: I tried it with a 480p preset and it was WORSE!

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:29 PM   in reply to Steven L. Gotz

    I have proven that the export is fine

     

    Mine came out with the error, which was how I first noticed the issue.  Watching a title that started over video and then continued over black, I could see a very noticeably shift in thickness once the title hit the black clip underneath.

     

    Try this experiment.  Add a normal title over a black clip, just like we've been doing for years.  With GPU acceleration on, turn off and on that black clip with the track eyeball.  You'll see the title change thickness.

     

     

    It is one of my new standard presets

     

     

    30P?  Really?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:44 PM   in reply to Jim Simon

    Mine came out with the error 

     

    I think your issue and the one we are addressing here are different. It is only a matter of the preview. I can see where what you describe can be a problem, but that would be due to bleed through of the black through the less opaque portions of the font.  In this case, I have no black. The difference shown in Bill's example is from making changes to the Mercury engine between hardware and software only.

     

    30P?  Really?

     

    One of three. I use 24p for scripted video (or semi scripted anyway).

     

    I use 60p for some video I shoot, and if quality is the main issue, I stick to all I-Frame using 30p.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:49 PM   in reply to Steven L. Gotz

    I suspect the underlying issue is the same, at least for the OP.

     

    I guess once he removes the clip under the title, we'll know, and can proceed from there.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:52 PM   in reply to Jim Simon

    I could be wrong, but I assumed that the clip under the title was the shiny thing the text is on. If that is removed he has black text on nothing. A black frame.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:54 PM   in reply to Steven L. Gotz

    That would need to be brought into the title itself, not added underneath.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 7:56 PM   in reply to Jim Simon

    Jim Simon wrote:

     

    That would need to be brought into the title itself, not added underneath.

    It certainly could not hurt to try.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 8:32 PM   in reply to Steven L. Gotz

    I have a similar problem that I got very little response to on this forum:

     

    Notice outer edge of text with MPE in Hardware Mode:

     

    Graphic w-MPE in Hardware mode.jpg

    Image with MPE in Software Mode:

    Graphic with MPE in Software mode.jpg

    The Software mode is the intended look.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2013 9:29 PM   in reply to FelixUnderwood

    The Software mode is the intended look.

     

    Then you'll need to run in that mode.  GPU processing does things differently.  You're seeing that difference.

     

    "CUDA-accelerated processing is done in a linear color space (i.e., gamma = 1.0) at 32 bits per channel (bpc), which results in more realistic results, finer gradations in color, and better results for midtones."

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 18, 2013 6:00 AM   in reply to Jim Simon

    Jim, then isn't this the same issue that the originator of this thread is experiencing with his text issue?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 18, 2013 1:31 PM   in reply to FelixUnderwood

    Sort of.  I think what you're seeing is the way it works.  I think what the OP is seeing is a bug when any non-video is placed beneath a title.  Might be an alpha thing.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2013 11:27 AM   in reply to Malcev.Z

    Having identical issue on the Mac side, 100% reproduced.  Basic font over rolling video.  Font is significantly thinner with cuda acceleration on, and correct with cuda off. Basic logos in Titler appear to be affected as well.  Must be problems with alpha + cuda.  Has anyone filled out a ticket, or has any Adobe rep acknowledged this?  It's a pretty big issue.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2013 1:43 PM   in reply to Steven L. Gotz

    Steven L. Gotz wrote:

     

    I was hoping to have Kevin chime in. If he doesn't  then I will put in the report.

     

    Edit: I keep thinking that this would be easier if we just got on a conference call. You know?

     

    Sorry I am late to this conversation. While I don't know precisely what's happening here, I would suspect it has to do with GPU processing in linear color. In Premiere Pro CC, we have a new feature that will help problems like this. In Sequence Settings, you can enable "Composite in Linear Color." See the screenshot below:

     

    Screen Shot 2013-05-10 at 1.37.20 PM.png

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2013 1:58 PM   in reply to Kevin Monahan

    In Sequence Settings, you can enable "Composite in Linear Color."

     

    The new feature is actually the ability to disable it.  Currently with GPU acceleration on, you have no choice but to use Linear Color.  With Premiere Pro CC users can turn that part of it off, while leaving GPU acceleration as a whole turned on.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2013 9:00 PM   in reply to Jim Simon

    With Premiere Pro CC users can turn that part of it off...

     

    I just love having choices. Fix or no fix, it doesn't matter if I can change it to the way I want it.

     

    I am looking forward to Premiere Pro CC

     
    |
    Mark as:
  • Currently Being Moderated
    May 15, 2013 6:39 AM   in reply to Kevin Monahan

    Kevin,

     

    Out of curiosity, in CS6 is there any scenario in which font and/or logos created in the titler, placed directly over a video clip in a sequence appears correctly when Cuda acceleration is enabled?

     

    I'm trying to figure out if there is any workaround, or if I'm dead in the water to edit the basics in Premiere with hardware acceleration enabled.

     
    |
    Mark as:
  • Currently Being Moderated
    May 15, 2013 7:44 AM   in reply to gandem_

    In my experience, this issue only seems to occur over a graphic, not video content.  I see no change over video on my end, so if you are, something else may be going on.

     
    |
    Mark as:
  • Currently Being Moderated
    May 15, 2013 2:48 PM   in reply to Jim Simon

    Seeing this exact behavior on two mac rigs, and one pc rig.  This is a significant flaw.

     

    Would like Kevin to comment on scenario question.

     
    |
    Mark as:
  • Currently Being Moderated
    May 15, 2013 6:18 PM   in reply to gandem_

    I believe that Kevin already provided the answer that there is a fix, or at least a workaround, in Premiere Pro CC. So starting on June 17th, you should be good to go. Assuming you subscribe.

     

    I don't see any way to fix this in CS6 since they don't intend to upgrade CS6 once the new software is available (with some exceptions).

     

    But it is certainly worth asking him again, just in case.

     
    |
    Mark as:
  • Currently Being Moderated
    May 16, 2013 6:59 AM   in reply to Steven L. Gotz

    I don't believe this would be an upgrade to CS6, it would be a repair.  Apparently, it has never worked properly.

     

    There should be a patch to fix CS6, if it is in fact this linear color issue.  I think it's a bit outrageous that you can't create a font only name super in Premiere's CG with hardware acceleration turned on.  We're only talking about the basics here.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points