Skip navigation
Mrs. Photo
Currently Being Moderated

Photoshop Elements crashes

Apr 25, 2013 3:48 PM

Tags: #photoshop_elements_10

Why does Photoshop Elements 10 keep crashing and freezing my computer? I lost a potential sale today because of this crashing/freezing.

 

Message title was edited by: Brett N

 
Replies
  • Currently Being Moderated
    Apr 25, 2013 3:49 PM   in reply to Mrs. Photo

    Has it worked correctly in the past? Is there an error message? What are you doing at the time of the crash? Is it the Organizer or the Editor or both that crashes?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 25, 2013 7:00 PM   in reply to Mrs. Photo

    If it's just a random crash in the Editor (I found PSE8 would crash if I used the arrow keys after a applying a style for eg...)

     

    You can try:

     

    a) rebootinging the PC

    b) resetting the preferences (try holding down the Ctrl+Alt+Shift keys (Command+Option+Shift for Mac) while starting Elements 10. When it asks if you want to delete your preferences, click "Yes".)

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 25, 2013 9:49 PM   in reply to mshanhun

    Hi,

     

    Please try couple of probable solutions as mentioned below:

     

    Solution 1:

    1. Close Elements.

    2. Launch the Photoshop Elements Welcome Screen and hold down ctrl + alt + shift as you click Editor.

    3. Continue to hold the keys until you see a message box asking if you want to delete Photoshop Elements settings file; click Yes. Elements will open with default preferences.

     

    Solution 2: In case any network printer is attached try to launch without network or printer uninstall or make different printer as default.

    Solution 3: Try launching with anti-virus off or removing PSE from conflicting list.

     

    Solution 4:

     

    On the drive on which you have installed PSE,on my machine it is on C:

       

    Go  to C:\Program Files\Adobe\Photoshop Elements  10\Locales\<locale>\Plug-Ins\Import-Exportand you will find twain  plug-in. Remove that plug-in from that location and copy it somewhere  else.

       

    Now launch PSE and check if it works.

       

    For related post for Twain please see this:http://forums.adobe.com/message/2954743#2954743

     

    Thanks,

    Garry

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points