Skip navigation
Currently Being Moderated

Suddenly cannot adjust table width via sizing handles

Apr 30, 2013 4:36 PM

Tags: #framemaker #tables #framemaker_10 #structured_framemaker #table_columns

I have found the cause of this, and it is rather bizarre:

 

Using Structured FM, 10.0.2.419, on a Windows 7 Ultimate (32-bit) OS.

 

Today I noticed I cannot resize table columns in the usual way, by selecting more than one row in the column and dragging the sizing handles that appear at the edge of the column.  The sizing handles appear there when rows are selected, but I cannot "grab" them.  Instead, when I try to click on a handle, the row selection is lost.  The table has no straddled columns or rows, no hidden/conditional text.  I have tried on several different types of tables all with the same non-result.  The document is otherwise editable.

 

I am forced to use the Resize Column dialog box, which is not so fast or easy as just grabbing the column edge and visually adjusting it.

 

I have rebooted my machine with no change in the problem.

 

====================

 

Resolution:

 

The problem appears to occur when I have various panels/pods open (and set to stay open, not iconify after use).  In this case I was working with conditional text, deleting some no-longer-used conditions from my documents.  I had three conditional text panels open in my workspace, ADD/EDIT CONDITION TAG, SHOW/HIDE CONDITIONAL TEXT, and CONDITIONAL TEXT.  The last two were "merged" into a single panel, and all panels were set permanently open using the double right-arrows in the panel dark frame at the top.

 

It turns out when I collapse some or all of these open panels, I can select the table resize handles and adjust the column widths visually.  When I have all three pod panels expanded, the resize handles are ungrabbable.

 

Forgive me if I'm not using "pod" and "panel" precisely accurately - I just use them (or more often try to work around them) rather than worrying about the names Adobe has chosen.  By giving users SO much flexibility, I personally think they have made an awful usability mess of the product.

 

In any case, the problem seems to be solved, and I am posting this in case it can be helpful to anyone else.

 

Thanks.

 

-- garyZ

 
Replies

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points