Skip navigation
Crasmuss206
Currently Being Moderated

HELP I am doing a Data Merge and It is only giving me one record per page!

May 2, 2013 8:50 PM

Tags: #data #cs5.5 #merge #layout #master #page

I really need help here.  I am doing a data merge and have selected the options for doing multiple records per page but instead it is merging everything to it's own page.  Can someone tell me what I am missing?

 
Replies
  • Currently Being Moderated
    May 2, 2013 10:31 PM   in reply to Crasmuss206

    Is the text frame you are placing the merge into small enough for more than one frame per page?

     

    Mike

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2013 3:47 AM   in reply to Crasmuss206

    The fastest way for us to see the problem is if you show us a screen capture of the template page with frame edges showing.

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2013 10:00 AM   in reply to Crasmuss206

    I need to see the WHOLE page to confirm, and it would be good to see the Pages panel open, too, but my instinct is you probably also have a footer on this page. I also looks like it's page 3, which may also be a contributing factor.  General principles for multiple copies per page:  Restricted to a single page template document. If the placeholders are on the document page, ID will attempt to reproduce ALL of the content on the page, so you don't want anything on the page but the placeholders or there likely won't be any way for ID to duplicate without leaving the page. I suggest using the None master, then assigning your master with the headers and footers to the document pages AFTER the merge has been completed.

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2013 10:16 AM   in reply to Crasmuss206

    Try applying the None master....

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2013 10:29 AM   in reply to Crasmuss206

    Show me the page with the None master applied and Edit > Select All.  Also show me the Data merge dialog with the multiple records per page settings showing.

     
    |
    Mark as:
  • jmlevy
    477 posts
    Oct 30, 2004
    Currently Being Moderated
    May 3, 2013 10:31 AM   in reply to Crasmuss206

    Is your placeholder a table? It looks like, and unfortunately it can't work, except you use this script.

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2013 10:38 AM   in reply to jmlevy

    Why do you say you can't do a multiple record merge to a table?

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2013 10:43 AM   in reply to jmlevy

    I've never had any trouble putting placeholders into a table. It's the way I do most of the datamerge that I work with.

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2013 10:58 AM   in reply to Crasmuss206

    You still have extra stuff on the page. You want ONLY the placeholders. A multiple record merge uses the bounding box that encloses ALL of the content on the page to calculate where the next instance will be placed, and you don't have room on your page to duplicate everything.

     
    |
    Mark as:
  • jmlevy
    477 posts
    Oct 30, 2004
    Currently Being Moderated
    May 3, 2013 11:00 AM   in reply to Peter Spier

    Why do you say you can't do a multiple record merge to a table?

    I've never had any trouble putting placeholders into a table. It's the way I do most of the datamerge that I work with.

    My mistake… I was confused with the script, and I must confess I had never tried (until now) to use tables as placeholders, but it works.

    My apologies for this uncorrect answer

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2013 11:00 AM   in reply to Peter Spier

    By the way, I may have misinterpreted how you built that page. It seems your header and other "static" objects are on the document page instead of the master page. That would account for why the None master did not help.

     
    |
    Mark as:
  • Currently Being Moderated
    May 3, 2013 11:15 AM   in reply to Crasmuss206

    CS6 seems to have some trouble with knowing when there is enough space. The easy workaround is to set the right and bottom margins to 0 in the layout options.  And multiple record preview is known to be buggy. It's best to either take a leap of faith and merge without previewing, or Undo after previewing and before the actual merge.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points