Skip navigation
NVdesertluver
Currently Being Moderated

I have a new Epson R2000 and my prints are too dark.  How do I get WYSIWYG?

May 5, 2013 11:01 AM

Tags: #elements #photoshop_elements_10

I have turned off the color management on the R2000 and set Elements 10 to optimize for prints.  I am trying to get WYSIWYG.  This is complicated by a new LG Flatron IPS235 monitor.  It is supposed to have the best factory calibrated color and Fry's Electronics said that it would be the truest, full range color.  I have tried changing the mode to sRGB, photo mode, and user mode and the prints are always too dark.  I would appreciate any help I can get.  I am a scrapbooker working on photos of my world travel bucket list.  At the rate I am going, I will kick the bucket before I get any photos printed.   THANKS!

 
Replies
  • Currently Being Moderated
    May 5, 2013 11:10 AM   in reply to NVdesertluver

    Have you tried reducing the monitor's brightness setting?

     
    |
    Mark as:
  • Currently Being Moderated
    May 5, 2013 1:30 PM   in reply to NVdesertluver

    In addition to what hatstead said, are you making sure the right print settings are selected? (e.g., If you're printing on Epson's Photo Glossy paper, it *has* to be selected as the paper type via Epson's print management interface.)

     
    |
    Mark as:
  • Currently Being Moderated
    May 6, 2013 11:45 AM   in reply to NVdesertluver

      This goes against everything I have read about being sure that Photoshop controls the color. 

     

    Well, one can't believe eveything one reads. This problem comes up now and then on the forum pages, and we have been recommending to have the printer manage color, certainly not both PSE and the printer.

    I have Epson and Lexmark printers, and I have it set up to let the printer manage color.

    Works well on both units.

    Thanks for getting back to us.

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2013 12:43 PM   in reply to NVdesertluver

    If there is a "16 bit" option in the Epson controls, try turning it off.

    Apparently enabling that control breaks the color mangement code in the Epson driver.

     

    Letting Photoshop control color is more accurate, but sometimes runs into bugs in the printer driver code (like the 16 bit switch).

    Letting the printer control color is easier, but far less accurate and leaves your images subject to whatever secret sauce the printer driver wants to apply to them (which can vary between images!).

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2013 1:41 PM   in reply to Chris Cox

    Chris Cox wrote:

     

    If there is a "16 bit" option in the Epson controls, try turning it off.

     

    A. Where is that to be found?

    B.  Have not heard back from OP if issue persists.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2013 12:26 PM   in reply to hatstead

    A. In the Epson print driver dialog.

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2013 2:49 PM   in reply to Chris Cox

    Maybe in driver dialog for some Epson models, but can't find it for my machine.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points