Skip navigation
JoC1965
Currently Being Moderated

I have just installed PSE11 on my Mac, running OSX 10.8.3, but it won't recognise my Cannon EOS600D?

May 13, 2013 11:28 PM

I have just installed PSE11 on my Mac, running OSX 10.8.3, but it won't recognise my Cannon EOS600D?

 
Replies
  • Currently Being Moderated
    May 14, 2013 5:05 AM   in reply to JoC1965

    Editor>Help>Updates

     
    |
    Mark as:
  • Currently Being Moderated
    May 14, 2013 5:39 PM   in reply to JoC1965

    Hi JoC1965,

     

    From the Editor click Help>Updates

    There should be a camera raw update available.

     

    Let us know if you have trouble

     
    |
    Mark as:
  • 99jon
    12,867 posts
    Jan 6, 2010
    Currently Being Moderated
    May 17, 2013 4:47 AM   in reply to JoC1965

    If you hit the delete key you will be asked to confirm you want to delete the photo(s) from the catalog.

     

    To delete an item right-click (or hold two fingers on the track pad) on the green album icon under the thumbnail and choose remove from album.

     

    You can also select a batch of thumbnails in an album and click on a green icon to remove them all from the album.

     

    If you cant see the green album icons, move the zoom slider slightly to the right to make the thumbnails bigger.

     

    album-icon.png

     

    Try again from the Organizer with your 600D. After launching the Organizer app press Cmd+G for the downloader. Connect your camera and try refresh from the top pull down menu or try browsing for your device.

     

    If it is still not working copy your files from the storage card to a folder in Pictures. Then use the menu:

     

    File >> Get Photos & Videos >> From Files & Folders

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points