Skip navigation
enigma.cat
Currently Being Moderated

AVI files suddenly are corrupted.

May 22, 2013 11:34 PM

I'm having horrible trouble with AVI files.  I have two school projects in elements 11 which link to AVI files made with a canon powershot.  They were fine a couple of days ago, but now the AVI files won't load.  my projects are due soon, and I can't fix it.  Can anyone help?

 
Replies
  • Currently Being Moderated
    May 23, 2013 5:14 AM   in reply to enigma.cat

    It's likely that these AVIs use the MJPEG codec, which Premiere Elements can have problems with.

     

    Open one of these AVIs in G Spot or Media Info and check the codec listed. MJPEG vide is best edited with Windows MovieMaker or iMovie.

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2013 5:41 AM   in reply to enigma.cat

    enigma.cat

     

    The "worked before but not now" aspect of your issue interested me.

     

    Could you clarify.

     

    a. Are you saying that you have additional Canon (same camera) videos that you want to import into an already started project containing files from this camera and that these additional avi files will not import into that project? If so, do you get an error message and what does it say?

     

    b. What happens if you import these problem .avi files into a new project?

     

    c. What happens if you import again into the current project the .avi that imported with no problems the other day?

     

    If you had not written that these .avi files imported into your project the other day, I would have suggested

    a. convert the file to another format if it was established that you are shooting MotionJPEG.avi

    or

    b. download and install the Morgan MotionJPEG codec if it was established that you are shooting MotionJPEG.avi.

    http://www.afterdawn.com/software/audio_video/codecs/morgan_m-jpeg_cod ec.cfm

     

    I am not sure at this point if we are talking about a codec issue or a damaged project issue.

     

    Looking forward to your follow up.

     

    Thanks.

     

    ATR

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2013 9:52 AM   in reply to A.T. Romano

    Along with the answers to ATR's questions, I have one more:

     

    Since you stated that the AVI files did work, but not now, have you, by chance, changed your computers, or have you reinstalled the OS, or made any similar changes?

     

    The reason that I ask that, is that it is common to have appropriate CODEC's on one machine, but not another. Also, it is common that when one updates their OS, or makes any significant changes, a CODEC that was once properly installed in the OS, is no longer properly installed.

     

    Please let us know a bit more, and good luck with your Projects,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2013 6:18 PM   in reply to enigma.cat

    Great news!

     

    Once, I would rush to recommend either the Morgan, or MainConcept MJPEG CODEC's, but more often, camera makers are really tweaking their versions of the MJPEG CODEC. Now, I recommend installing the one from the camera mfgr., which is more often included and installed with a utility for the camera - even if one never plans on using that software - installing it is often JUST to install their MJPEG CODEC into the OS.

     

    Good luck and happy editing,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2013 7:47 PM   in reply to Bill Hunt

    Hunt,

     

    Great news about enigma.cat's problem being solved, especially in view of the deadline for the project involved.

     

    But consider

    They were fine a couple of days ago, but now the AVI files won't load.

     

    How do we explain "it worked" presumably after use of camera manufacturer's software/codec contribution when enigma.cat stated at the onset that there was no problem with these .avi files only a few days ago when the camera manufacturer's software/codec was not installed?

     

    ATR

     
    |
    Mark as:
  • Currently Being Moderated
    May 23, 2013 8:27 PM   in reply to A.T. Romano

    ATR,

     

    I can only speculate that something happened to the appropriate MJPEG CODEC's between the time that they worked, and then when they did not.

     

    I did not see if there was any change in the OS, or the computer, but that was why I asked my question.

     

    We often see a variation of this issue: "My AVI files (often with the MJPEG CODEC) work on my work computer, but not my home computer. Why?" In most of those instances, it is due to having the camera's utility software installed on the work computer, but not the home computer - for that example.

     

    We also see many cases where one has to reinstall the OS, and suddenly files that once Imported fine, no longer do. The solution is usually the same - install the camera mfgr's. version of the CODEC.

     

    Sorry that I do not have a definitive answer for you.

     

    Hunt

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points