Skip navigation
Currently Being Moderated

MPEG2-DVD / Sound cut off *urgent*

May 26, 2013 3:55 PM

Tags: #encore #sound_duration #mpeg2-dvd

Hi everyone

 

I have a very urgent problem which makes me lose my hair...

 

We have 190 minutes of 1920x1080 25p footage which we edited in Premiere Pro.

 

I then proceed to export the files into MPEG2-DVD using 2-pass VBR with 1,65/4,2/6.25 bitrate (according to an online bitrate calculator).

I multiplex the sound into the MPEG-2 file.

When I import the timeline into Encore, it correctly tells me "do not transcode".

 

BUT the sound cuts off short of the video. It does it for every chapter. I cannot 'extend' or 'pull' the sound to the length of the video.

First chapter is 24:19, sound cuts off at 23:15.

 

Anyone got an ìdea what I am doing wrong?

 

Any help is greatly appreciated!

 

Michael

 
Replies
  • Currently Being Moderated
    May 26, 2013 4:28 PM   in reply to President Beeblebrox

    >export the files into MPEG2-DVD... I multiplex the sound into the MPEG-2 file

     

    Those two statements are mutually exclusive (or, they should be !!!)

     

    The PPro MPEG2-DVD preset is designed to create TWO output files... one video and one audio... which you then import into Encore, at the same time, for DVD authoring

     

    When you multiplex into a single file, Encore has to do the added work of separating the audio/video for authoring

     

    So... which is it... are you creating two files with the MPEG2-DVD preset... or not?

     
    |
    Mark as:
  • Currently Being Moderated
    May 26, 2013 5:28 PM   in reply to President Beeblebrox

    You appear to have found a solution to your 1st play problem in http://forums.adobe.com/thread/894758

     

    >thought as long as I only have one audio track, it wouldn't matter.  That is not the case, I presume

     

    You presume correctly... the Premiere Pro export preset of MPEG2-DVD is designed specifically for when you want to export to... well... create a DVD

     

    The tutorial list in message #3 http://forums.adobe.com/message/2276578 may help

     
    |
    Mark as:
  • Currently Being Moderated
    May 28, 2013 8:57 AM   in reply to John T Smith

    Hi Michael,

     

    Your same issue has been posted a couple of times recently. Definitely the multiplexed audio causing the short audio in Encore. Use the DEFAULT export setting of NONE for Multiplexing and you should get the .m2v and .wav (PCM) files. In Encore, use "Import As > Timeline" and select BOTH files at once and they come into an Encore timeline together. Note that any DVD chapter markers added in Premiere will also import using this method.

     

    The video will NOT transcode (unless file is too large for disc) and the audio will very quickly transcode to the default Dolby Digital when Building. I noticed your average encode rate is 4.2 and that seems quite high for a 190 minute program. Are you burning to a dual-layer DVD? If not, the calculator I tried suggest a bitrate of 2.9 which seems more realistic for a 4.7GB DVD. Otherwise, Encore may need to re-encode the video again so it fits. More time and quality loss, so double-check those settings to get it right the first time.

     

    Thanks

     

    Jeff Pulera

    Safe Harbor Computers

     
    |
    Mark as:
  • Currently Being Moderated
    May 28, 2013 10:41 AM   in reply to SAFEHARBOR11

    SAFEHARBOR11 wrote:

     

    Hi Michael,

     

    Your same issue has been posted a couple of times recently. Definitely the multiplexed audio causing the short audio in Encore. Use the DEFAULT export setting of NONE for Multiplexing and you should get the .m2v and .wav (PCM) files. In Encore, use "Import As > Timeline" and select BOTH files at once and they come into an Encore timeline together. Note that any DVD chapter markers added in Premiere will also import using this method.

     

    The video will NOT transcode (unless file is too large for disc) and the audio will very quickly transcode to the default Dolby Digital when Building. I noticed your average encode rate is 4.2 and that seems quite high for a 190 minute program. Are you burning to a dual-layer DVD? If not, the calculator I tried suggest a bitrate of 2.9 which seems more realistic for a 4.7GB DVD. Otherwise, Encore may need to re-encode the video again so it fits. More time and quality loss, so double-check those settings to get it right the first time.

     

    Thanks

     

    Jeff Pulera

    Safe Harbor Computers

    Hiya Jeff.

     

    Importing a timeline is un-necessary and kinda silly at the same time, as it is far, far better to import the rendered elementary streams instead (M2V & WAV).

    Personally I would render from Premiere as a DV AVI file, and do the render for DVD in Encore - you will get a lot more control over the final disc this way as the bit budgeting can be set to Automatic (best for those who do not understand transcoding) or if confident set the transcoce up in Encore.

    A 190 minute program at 2.9Mbps will look awful - this is barely above the minimum quality specs and is for a single layer disc - I would never use 190 minutes on a single layer as the results will be far from pretty to look at.

    Use a DVD9 Dual Layer disc, and the following settings:

    Peak Bitrate - 5.7Mbps

    Target Bitrate - 5Mbps.

    If a very low bitrate is acceptable (4Mbps) then LPCM audio could be used. BUt I fail to see the point of a video bitrate of a pitiful 2.9Mbps.

     
    |
    Mark as:
  • Currently Being Moderated
    May 28, 2013 11:13 AM   in reply to Neil Wilkes

    Hi Neil,

     

    I think you misunderstood my post - I never said to "Import a Timeline" - rather, I suggested that IN ENCORE, one can use "Import AS Timeline" to import the .m2v and .wav files.

     

    As for the quality of the 2.9 bitrate, it depends on the subject matter. If the video is a locked-down tripod shot of a talking head at a conference, then 2.9 can look just fine! For a wedding or most videos with lots of motion, then I would agree that the results may not be very good at all and other options should be considered.

     

    Thank you

     

    Jeff Pulera

    Safe Harbor Computers

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2013 6:59 AM   in reply to President Beeblebrox

    Hiya Zaphod.

     

    I have occasionally seen something like this when there was a silent section at the start of the audio file.

     

    Can I ask what settings you used though, as this still seems wrong. Was it literally "separate exports" or 2 files from one export?

    If the former, what setting was used becomes important as there are mpeg-2 settings & then there are mpeg-2 for DVD settings.

     

    Also I wanted to say that mpeg audio really should be avoided as it is not your friend.

    It's only spec mandatory in PAL countries - in NTSC regions you may well get silent output as it is purely an optional codec there (it sounds pretty grim too)

     
    |
    Mark as:
  • Currently Being Moderated
    May 29, 2013 7:43 AM   in reply to President Beeblebrox

    On a computer based setup it would probably be okay - these players seem to be immune to a lot of the compatibility issues we see on hardware players,

    BUT - and this is a biggie - you will almost certaihnly run into trouble on set top hardware players. For maximum compatibility ion all areas, use NTSC for all.

     

    Another problem is the frame rate & resolution.

    PAL is 720x576 @ 25fps, NTSC is 720x480 @ 29.97fps - the video files will need to be standards converted to play properly on US TV systems.

    Oddly, in PAL regions you will usually find NTSC will play okay, either as pure NTSC or else as PAL-60 - but it rarely works the other way around & certainly cannot be guaranteed.

     

    Menus will be an issue as well, because of the Pixel Aspect Ratio question (and Widescreen is evil in this area) where PAL is 1.4:1 ratio and NTSC is 1.21:1 ratio.

    So your menus will have the wrong shape, and will need to be tweaked.

    There are ways around the menu issue - open your PAL one, stop the buttons showing, create an NTSC one & drop the background from the PAL into the NTSC.

    This will usually poreserve the Aspect Ratio correctly but you will lose vertical resolution. Video files must be standards converted though, and this is not as easy as it might be.

     

    Moving switftly onwards......by "2.1 seconds of silence" is this actual silent audio (as in the file is there but digital silence) or an actual, physical gap where the audio starts after the video? If the latter this can be easily sorted out by adding audioblack ( a silent section) in premiere - frame 1 of the video must align with sample 1 of the audio or all bets are off. That space - if it is a space - could well create your issues or the fault may be elsewhere. Can I see your Premiere Project file, or a screenshot of the start of the sequence in Premiere? None of these issues are Adobe's fault - it is the limitations of the DVD specifications and applies in all authoring tools (and believe me, they all have issues - the grass is not greener on the other side at all, it is an optical illusion!!)

     
    |
    Mark as:
  • Currently Being Moderated
    May 30, 2013 7:03 AM   in reply to President Beeblebrox

    To my knowledge, U.S. DVD players do not generally play PAL discs, so unless you can gaurantee that all viewers are using computers, there will be issues.

     

    As for audio, you say that you render as "MPEG2-Audio" - what is that?

     

    If you use ANY of the default "MPEG-2 DVD" templates, the default audio output is going to be .wav (on a PC, not sure what Mac does). AME will output .m2v video and .wav audio at the same time for use in Encore. The idea is that .wav is UNCOMPRESSED, so no quality loss from compression. Encore can then convert that .wav file to Dolby AC3, which is high quality. If you compress to "MPEG" or some other lossy audio format BEFORE it gets to Encore, then it is getting transcoded (re-compressed) again in Encore, from an inferior format to Dolby AC3.

     

    Jeff

     
    |
    Mark as:
  • Currently Being Moderated
    May 30, 2013 8:53 AM   in reply to SAFEHARBOR11

    I'm in complete agreement with Jeff here as well - selling PAL discs in the US will sooner or later cause problems.

    Priobably sooner.

    In the old days you would not get the player to even load them - it would throw a "no disc" or another error of some description - and even when you did find the odd rare one that would load them, the TV systems would make sure you got a garbled image, or a B&W one. These days a good Universal Player will usually load all types (although again a regular DVD player will most likey still not go for it) but you will still have TV system issues.

    The problem is the mains frequency - PAL (Europe) uses 625 lines and 50Hz whereas NTSC uses 525/60, which effectively means PAL runs at 25 frames/second & NTSC at 30 frames/second. The 2 are incompatible. Most PAL players can handle both formats either by outputting NTSC discs as PAL-60 or even genuine "on the fly" conversions to 525/60 NTSC.  The process is not straightforward either - the player is handling scaling, temporal conversion and object motion analysis all at once (Hence why most PAL setups output NTSC as PAL-60 instead of pure 525/60 NTSC) and additionally the audio speed must be adjusted (remember DVD is a multiplexed set of VOB files, not separate streams) to conform to the different display rate - which may also prevent the use of a digital connection!

    This type of conversion is much, much less compatible the other way around. Most NTSC players still cannot play PAL discs (although as I have said a Universal BluRay player may do this) and only a very small number can convert 625/50 PAL to 525/60 NTSC.

     

    Let us now talk about MPEG audio & why it is not recommended to use it. This gets complex.....

    MPEG audio is a multichannel format using perceptual encoding at 16-bit 48KHz. MPEG-1 Layer II and MPEG-2 BC (backwards compatible) are the only allowed forms and the MPEG-2 that is allowed - BC - is a matrixed format, not discrete, in surround use. Use of this type (MPEG audio) was only ever optional in NTSC, never mandatory (so that is one big problem) and the other big problem is that MPEG-2 audio is only allowed in BC mode. Why is this evil? Take a seat & let me try to go through it.

    Because MPEG-2 audio decoders were not available at the time of DVD introduction, MPEG-1 was the only decoder available so that was what got used. As a result, the only permissib;le type of MPEG-2 allowed is BC, which is a matrixed stream type (the 5 main channels are matrixed into Lt/Rt stereo streams) and then encoded in the normal MPEG-1 Layer II format for DVD. The advantage to this is that a multichannel stream can be phase matrix encoded so that it will also play on a stereo system. MPEG provides pre-determined matrixing formulas depending on the intended audience - one is a conventional stereo signal, another is designed to deliver a Dolby Surround compatible (*not* Dolby Digital - that is something very different) system that re-creates the centre channel fronm the left/right channels in addition to a single rear (or surround) channel (Nerdy Note - this is actually a development of the old SQ Quadraphonic matrixing system, set up for LCRS instead of L-R-Ls-Rs). Additional discrete channel information, plus the LFE channel, is encoded in an extension stream so that an MPEG-2 decoder (not MPEG-2 Audio) can recreate 6 separate signals. Because of the necessity to be backwards compatible with MPEG-1 decoders the centre & surround channels that are matrixed into the 2 MPEG-1 channels (left & right) are duplicated in the extension stream. This allows the MPEG-2 decoder to subtract those signals from the matrixed signals, leaving the original Left & Right channels. All this adds an overhead of approximately 32kbps, making it rather inefficient.. The original 2-channel MPEG-1 encoding process was not developed with matrixed audio in mind and therefore may actually remove surround detail. Also, the process tends to expose coding artefacts as well so coupled with the whole shebang only ever being optional in NTSC 525/60 systems means that to use this as your solitary stream type is actually out of spec for 525/60 regions & players may well take one look at the disc & output...................in short, just a picture. And if that picture is 625/50 PAL, quite possibly not that either.

     

    Audio support in DVD.

    MPEG-2 audio is basically not supported except in BC moide, which hands everything over to MPEG-1 decoders. This is not good. It is not efficient, it can be riddled with artefacts & it is not supported by fiat in NTSC regions, only optionally. If it is your sole stream you will run into trouble sooner or later.

     

    I hope this helps, and I think I will go away & write a little article about this as it keeps cropping up every so often..

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 4, 2013 12:52 PM   in reply to President Beeblebrox

    When exporting the .wav file for DVD, are you using 48k 16-bit stereo?

     

    Strange that length is not matching, this is not common at all

     

    Jeff

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points