Skip navigation
Currently Being Moderated

FLVplayback doesn't download progressively

Jun 2, 2013 3:47 PM

Tags: #as3 #flvplayback #download #load #source #progressive #flvplayback_component

Hello,

 

1) I have an flvplayback component that loads mp4 files rendered with H.264. I have used QTIndexSwapper to move the MOOV atom but still, my videos do not play until they are loaded (I also tried Sony Vegas mp4 rendering with Progressive Download option checked).

2) Also, on the same flvplayback I load multiple videos when buttons are clicked. What is the difference between myPlayer.load and myPlayer.source (AS3 parameters) for the component? Could that be the issue?

 
Replies
  • kglad
    72,274 posts
    Jul 21, 2002
    Currently Being Moderated
    Jun 2, 2013 4:15 PM   in reply to wolf14

    i've never had any problem but i don't use any of the 3rd party tools you mentioned.  if autoPlay is true, the video will start to play as soon as the source is assigned and enough video downloads to fill the buffer.

     

    the load() method allows you to start loading a video and NOT start its play until you specifically apply the play() method (or some other way start play).

     

    assigning the source is the typical way to play a video with progressive download (when autoPlay is true - which is the default value).

     
    |
    Mark as:
  • kglad
    72,274 posts
    Jul 21, 2002
    Currently Being Moderated
    Jun 3, 2013 6:33 AM   in reply to wolf14

    great.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points