Skip navigation
Currently Being Moderated

Web FTP connection issue

Jun 12, 2013 7:06 AM

Tags: #flash #as3 #flex #3 #actionscript #4.0 #builder #spark #flex4 #flex4.6

I am creating an web ftp example using flex 4.0, when i run the application from development environment (from flex) its connecting ftp server perfectly and working fine. But when trying to connect FTP server from release build version of application. Its not working.

 

What could be the possible reason to stop connecting FTP server from flex web ftp request?

 

On FTP connection request receive error:

 

Command socket error: [SecurityErrorEvent type="securityError" bubbles=false cancelable=false eventPhase=2 text="Error #2048: Security sandbox violation: http://localhost/YemoWebFTP/WebFTP.swf cannot load data from 10.0.2.197:21]

 

Also using crossdomain.xml as follow:

 

<?xml version="1.0"?>

<!DOCTYPE cross-domain-policy SYSTEM "/xml/dtds/cross-domain-policy.dtd">

<!-- Policy file for xmlsocket://socks.example.com -->

<cross-domain-policy>  

 

   <site-control permitted-cross-domain-policies="all"/> 

 

   <!-- Instead of setting to-ports="*",administrators can use ranges and commas -->

    <allow-access-from domain="*" secure="true" to-ports="21,80, 843, 1024-3000" />

 

          <allow-http-request-headers-from domain="*" headers="*"/>

 

</cross-domain-policy>

 

 

And from application before connection request to FTP server

 

Security.loadPolicyFile("http://10.0.2.197/crossdomain.xml");

 

Additionaly, also tried:

 

Security.allowDomain("*");

Security.loadPolicyFile("xmlsocket://10.0.2.197");

 

Thanks in advance.

 

Bharat

 

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points