Skip navigation
rgrant19932
Currently Being Moderated

Problem setting up AMS with external APACHE

Jun 16, 2013 6:26 PM

Tags: #problem #issue #server #installation #localhost #wont_start #ams #external_apache

I have been reading for days online switching back and forth between using Adobe Media server(AMS) and RED5, The lack of documentation related to RED5 led me to adobe.

All i need is video streaming for mp4 video files to work on my current website i have set up.

 

My local host is 192.168.1.13

 

 

I downloaded AdobeMediaServer_5_LS1_win64.exe (free version).

Installed with apache (to get the dll files i needed listed on this page http://help.adobe.com/en_US/flashmediaserver/configadmin/WSd391de4d9c 7bd6093a7e2f8312a374a1bde-8000.html#WS565cbb3ff5441e2614fa39ef13121395 a10-8000)

The files are:

  • rootinstall/Apache2.2/modules/adbe_dme.dll
  • rootinstall/Apache2.2/modules/adbe_license.dll
  • rootinstall/Apache2.2/modules/asneu.dll
  • rootinstall/Apache2.2/modules/hds.dll
  • rootinstall/Apache2.2/modules/libeay32.dll
  • rootinstall/Apache2.2/modules/libexpat.dll
  • rootinstall/Apache2.2/modules/mod_f4fhttp.so
  • rootinstall/Apache2.2/modules/mod_hlshttp.so
  • rootinstall/Apache2.2/modules/mod_jithttp.so

 

Copied ALL of those files into my existing apache modules folder

Unistalled AMS, Then Reinstalled using default ports (port 80 collides with port 80 set up by apache but i am ignoring that for now).

     Im ignoring the collision with port 80 because, i believe i dont need the AMS service to be running on my pc if i set it up with my current apache?

 

Then i went to my current apache htppd.conf file located at (C:\xampp\apache\conf\httpd.conf)

 

Added the module line:

 

LoadModule f4fhttp_module modules/mod_f4fhttp.so

<IfModule f4fhttp_module>

<Location /hds-live>

    HttpStreamingEnabled true

    HttpStreamingLiveEventPath "C:\xampp\htdocs\site\archives\01_archive\streaming"

    HttpStreamingContentPath "C:\xampp\htdocs\site\archives\01_archive\streaming"

    HttpStreamingF4MMaxAge 2

    HttpStreamingBootstrapMaxAge 2

    HttpStreamingFragMaxAge -1

    HttpStreamingDrmmetaMaxAge 3600

    Options -Indexes FollowSymLinks

</Location>

</IfModule>

 

 

I have no clue what this module is doing but i copy and pasted the code from (http://help.adobe.com/en_US/flashmediaserver/configadmin/WSd391de4d9c7 bd6093a7e2f8312a374a1bde-8000.html#WS565cbb3ff5441e2614fa39ef13121395a 10-8000).

 

I know port 80 is colliding with the apache used in my xampp server so i go to my computers services and turn off Adobe media server (because my current thought is that i wont need the service because i am installing it on my current apache server).

 

Then I attempt to start apache from xampp and it refuses to start with out saying that it failed, aswell as not showing any errors in the error log.

 

BUT, when i change LoadModule f4fhttp_module modules/mod_f4fhttp.so to #LoadModule f4fhttp_module modules/mod_f4fhttp.so the error goes away and apache starts.

 

 

QUICKLIST:

1). Do i need Adobe Media server to be running in my services if i am using an external apache?

2). Why won't my apache start?

3). What ports should i use while installing my AMS if i am going to use an external apache?

 

My answers correct me if i am wrong:

1). Pupils whom are setting up AMS with an external Apache server are installing the AMS on that server, so the need for the AMS service to be running is not needed.

2). My theory of why AMS is not running is because the line LoadModule f4fhttp_module modules/mod_f4fhttp.so is calling the the line is succeeding the conditioned module / function one a syntax is incorrect, though this is unlikely due to adobe provide this code themselves.

3).Pupils setting up an external apache with AMS should not use port 80, because it will collide with your apache server for http.

 

 

Any help/guidance is apeciated i am new to AMS, but i believe i have provided every possible detail that could solve my issues. Hours of meaningful research will continue until i find the solution.

 
Replies
  • Currently Being Moderated
    Jun 16, 2013 11:47 PM   in reply to rgrant19932

    Hello,

     

    First to solve your problem. I am assuming your apache installation on windows is 32 bit because the Apache modules that ship with AMS are all 32 bit.

     

    Also, do you see mod_ctrlplane.so in the bundled Apache? You need to copy that as well.

     

    If the use case just to be able to play mp4 files, you don't need AMS service running.

     

    -Karishma

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2013 1:05 AM   in reply to rgrant19932

    So did Apache not start or you are getting error when your request is being served? Because I see Apache writing errors when you call loadvid.php...so it must be up to write that.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2013 1:06 AM   in reply to KarishmaB

    Also can you change the logLevel to info in httpd.conf? I don't see any AMS Apache module logs here

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2013 1:21 AM   in reply to rgrant19932

    What makes you say Apache didn't start? You don't see it running in task manager?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 17, 2013 2:02 AM   in reply to rgrant19932

    Ok but nothing in the log says that Apache didn't start.

    Just to play a mp4 file, you can comment this. But then you get only the capability to play mp4 files and not hds live.

    Unfortunately I can't provide you any instructions with xampp. From AMS perspective this should work.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points