Skip navigation
Ollie Edge
Currently Being Moderated

Using iOS Simulator via Flash Builder on OS X 10.9 Mavericks

Jun 17, 2013 2:02 AM

Tags: #osx #simulator #flash_builder_4.7 #mavericks #10.9

Hey Everyone,

 

You will find that if you have updated to OS X Mavericks (currently BETA 13/05/13) the iOS Simulator will not activate from the Flash Builder IDE. FB will prompt to saying you need to enable assistive devices but Mavericks has removed this option from the Universal Access option in the system preferences.


Here is the work around:

 

Activate System Events:

System Preferences > Security & Privacy > Privacy > Accessibility > Tick System Evenh

 

There is no need to restart Flash Builder the simulator should now just work fine.

 

 

Hope that helps prevent a lost few minutes on the old google machine.

 
Replies
  • Currently Being Moderated
    Oct 23, 2013 10:42 AM   in reply to Ollie Edge

    I hate to dig up an old thread, but this is the top result when Googling for "flash builder assistive devices" and I want to note that this isn't entirely true anymore in the final release.

     

    You need to now:

    1. Try to run iOS Simulator debug from Flash Builder. Select "Yes" in the menu that it gives you
    2. Open System Preferences > Security & Privacy > Privacy > Accessibility
    3. Make sure System Events.app is selected
    4. Restart Flash Builder
    5. Back in System Preferences, an option for Flash Builder.app will now be present as well. Make sure this is selected too

     

    That should allow you to debug in the iOS Simulator again.

     

    Thanks for pointing me in the right direction.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)