Skip navigation
jschneidercssi
Currently Being Moderated

Web service access error:  javax.servlet.ServletException: https is forbidden

Jun 17, 2013 11:43 AM

We have Coldfusion 10 configured on an IIS web site using a GoDaddy provided SSL certificate.  When we try to access a web service we receive a 500 error from the server.  When we look at the application log we see the following record:

 

"Error","ajp-bio-8012-exec-2","06/17/13","14:20:19","SmartPriceAdmin", "The web service operation caused an invocation exception.The root cause was that: javax.servlet.ServletException: https is forbidden The specific sequence of files included or processed is: C:\WebSites\Something\SMARTPriceServices.cfc'' "

 

 

C:\WebSites\Something\SMARTPriceServices.cfc is the location on the server where the actual web service file resides.

 

 

I'm not the sites developer but I'm trying to aid him in finding the issue.  We've added the sites SSL certificate through the SSL Certificate Management feature of the Administrator and restarted the Coldfusion 10 Appllication Service but it had no effect.  Any help would be very appreciated.

 
Replies
  • Currently Being Moderated
    Jun 17, 2013 3:08 PM   in reply to jschneidercssi

    Can you access a CFM inside the directory? It might be IIS configuration issue.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2013 6:06 AM   in reply to jschneidercssi

    I'm almost certain that the issue is related to Web server configuration with SSL installed.

     

    Try this and see if that works. In the CF Admin, there is a way to flush out generated CFC files.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2013 11:47 AM   in reply to jschneidercssi

    The issue is because by default Axis is set to only permit HTTP calls and not HTTPS.  You have to update the ColdFusion10\cfusion\wwwroot\WEB-INF\Axis2.xml file to enable the HTTPS mode.  I found Apache documentation on it here;

     

    http://axis.apache.org/axis2/java/core/docs/servlet-transport.html

     

    Using their documentation I changed it from this;

     

    <transportReceiver name="http" class="coldfusion.xml.rpc.CFAxisServletListener"/>

     

    to this

     

    <transportReceiver name="http" class="coldfusion.xml.rpc.CFAxisServletListener">
        <parameter name="port">8080</parameter>
    </transportReceiver>

     

    <transportReceiver name="https" class="coldfusion.xml.rpc.CFAxisServletListener">
        <parameter name="port">8443</parameter>
    </transportReceiver>

     

    I'm still testing though to see if this works correctly

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2013 12:54 PM   in reply to Leith Tussing

    Hi,

     

    Can you please check which Axis is selected in your ColdFusion Admin. If it is Axis 2, then try to add the transport receiver for HTTPS which Leith mentioned and restart the service. Also you can try with Axis 1.

     

    Hope this helps.

     

    Regards,

    Priyank

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2013 12:55 PM   in reply to Priyank Srivastava

    Of note I had to change the port #'s to be 80 & 443 to match those of the websites running under IIS.  When the ports didn't match the calls would fail.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points