Skip navigation
Currently Being Moderated

Photoshop CC Live Shapes Properties Bug

Jun 18, 2013 9:35 AM

Tags: #bug #photoshop_cc #live_shape

Checking out the corner radii controls on vector shapes and it looked to be working, until I created a couple of other shapes. The Properties box inconsistently changes for the same kind of shapes.


Link to vid to show my problem: http://cl.ly/PheD

 

Looks like I can't go back to edit the shape for some reason. What would cause this? It's like the shape has suddenly stopped being a Live Shape.

 

Cheers!

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Jun 18, 2013 10:13 AM   in reply to jack_bingham

    Hi Jack,

     

    I moved your discussion from the Creative Cloud forum to the Photoshop forum, where you may get more relevent help more quickly.

     

    Could you please post a screenshot of your layers panel?

     

    Michael

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2013 10:54 AM   in reply to jack_bingham

    What happens if you use the Path Selection Tool to select the shapes instead of the Move Tool?

     

     

     

    Untitled-2.png

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2013 2:37 AM   in reply to mjarrott

    I have also found this when copying a live shape using the layers panel. When I select the copy the live shape properties are not available. Seems that using the direct selection tool usually switches it back.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 22, 2013 10:32 AM   in reply to jack_bingham

    Hi,

     

    This bug goes a lot further than what you have stated, if you select the live shape from the tool menu on the left it removes the properties and the width becomes the width of the space.

     

    Very strange issue's happening.

     

    These silly bugs needs sorting out ASAP.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2013 2:30 PM   in reply to jack_bingham

    Hi Guys,

     

    I have same problem with my CC. Live shape properties just missing when I select shape object.

     

    Cheers,

    Michal

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 24, 2013 8:11 AM   in reply to michalsemela

    Yes I only managed to get the live shape properties to work when reselecting an object once. Pity as this was the feature that made me want to upgrade.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 25, 2013 7:41 AM   in reply to jack_bingham

    I've got the same problem. When alt-copying a live shape all seems fine, but when I copy the shape via the layer panel the live shape properties disappear!

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 25, 2013 5:45 PM   in reply to pvbeee

    Stop the insanity.

    https://sphotos-a.xx.fbcdn.net/hphotos-frc3/996863_10151754854240719_844700773_n.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 25, 2013 5:53 PM   in reply to keith_harper

    It appears that PS is losing the shape's designation as a rectangle with round corners – if I create a triangle immediately after making a rect with round corners, it loses its original options.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 27, 2013 8:20 AM   in reply to keith_harper

    I get exaclty the same issue - although right from the start I never see the correct Properties panel for Live Shapes. I also see the MASK panel as shown in the post above

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 27, 2013 10:48 AM   in reply to jack_bingham

    I am also experiencing the same issue.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 28, 2013 11:18 AM   in reply to jack_bingham

    Same problem here. It's indiscriminate. Sometimes it only shows Masks rather than Live Shape Properties. Very annoying.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2013 6:58 AM   in reply to pixxelco

    Wondering why there has been no response about this issue. Still seeing it occuring today.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2013 7:03 AM   in reply to arctechnologysolutions

    My issue was somewhat skewed by the fact that Adobe seems to have 'stealthed' Adobe CC in as opposed to the cloud based CS6 we are signed up for. That feature works fine in CC but not in CS6, so we had to download and install that version now.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2013 7:06 AM   in reply to CS-Marcus

    I am currently using Photoshop CC and have uninstalled CS6 and I am seeing this issue. Maybe a reinstall fixes it; is that what you were saying?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2013 7:22 AM   in reply to arctechnologysolutions

    No you are right, I now have a 'bug' error. So it basically forgets its a 'Live Shape' after you create others and go back to it. So you cannot edit it after a while. I assume this is a bug Adobe will fix. However previously I have CS6 which doesnt include this feature at all (or certainly it wasn't working on ours)

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 4, 2013 1:52 AM   in reply to jack_bingham

    I have the same issue, but then I found out you have to use the path selection tool to select the shape. The properties show up after a lag though. I also encountered a decimal bug. Values becomming 300,99 but visually it is still correct. Very annoying.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2013 12:16 PM   in reply to jack_bingham

    Is there an ETA on this issue?... Does anyone else have issues resizing the rounded rectangles after it switches from 'live shape'?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2013 3:43 PM   in reply to jack_bingham

    Well, it's also the same for us. Please adobe fix this issue, it is quite annoying and affecting our workflow...

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 24, 2013 7:54 AM   in reply to CS-Marcus

    Not only does it forget that you have a live shape, you can not create a new live shape if the you have a shape layer selected. You would need to select a raster layer or group to create a new live shape... that it later forgets that it's a live shape.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2013 2:44 PM   in reply to jack_bingham

    Hello,

     

    As a couple of people have mentioned in this thread, the Live Shapes Properties panel displays based on which subpaths are currently targeted. By targeted, I mean that the anchor points on the path are visible and at least one is filled. Clicking on the shape with the Path Selection tool is the easiest way to target a subpath. You can add to the targeted subpaths by Shift-clicking additional shapes with the Path Selection tool (or Shift-dragging around the shapes you want to select). Using the Move tool won't work for this, since it only selects the layer and not the path(s).

     

    We implemented it this way because now that Photoshop has multiple path selection and there are so many combinations of ways to select different kinds of paths, it can get really buggy when Photoshop has to make assumptions about exactly what the user meant to select. This way, it's obvious which subpaths are targeted.

     

    We are continuing to look into ways to improve the way the Properties panel works for live shapes. I see that a couple of bugs are mentioned here in addition to the issue with accessing the Live Shape Properties panel.

     

    Not only does it forget that you have a live shape, you can not create a new live shape if the you have a shape layer selected.

    This should be possible. Could you post the list of steps you're using when you run into this problem?

     

    This bug goes a lot further than what you have stated, if you select the live shape from the tool menu on the left it removes the properties and the width becomes the width of the space.

    I'm not sure what you mean by this -- could you also post a list of steps?

     

    Thanks!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 19, 2013 12:55 AM   in reply to Jeanne Rubbo

    I made a little video of how this bug looks on my Mac:

     

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 21, 2013 12:27 PM   in reply to inteilla

    Hi inteilla,

     

    Are you using Photoshop CS6? The Live Shapes Properties panel was introduced in Photoshop CC.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2013 11:52 AM   in reply to jack_bingham

    Same problem here.

     

    Still no fix?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2013 11:58 AM   in reply to DamianHdez

    Guess they don't consider it a priority.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2013 9:01 PM   in reply to Jeanne Rubbo

    Hi Jeanne,

     

    There is definitely an intermittent bug that prevents accessing the properties panel of the paths as everyone has been stating and as shown in the images posted previously by Keith Harper on post number 10. That images shows what the main problem is, the image in the left is what should be available but the one on the right is what randomly shows up. I thought the problem went away when I changed from the “direct select” to the “path select” tool but that was just a random event, it was not the solution.

     

    When the fault appears and I copy the individual layer to a new document, the problem is still there, of course creating a new shape on a new layer, the properties panel shows up like it should, but then clicking on the original shape layer with the problem the properties still cant be accessed

     

    Hope they solve this soon, because the new shape functions are really cool until the frustration of this bug takes over

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2013 4:02 AM   in reply to jack_bingham

    I also have this issue. Adobe please fix this asap!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2013 7:54 AM   in reply to jack_bingham

    Same issue,

     

    Live shape properties get removed when re-selecting the "same tool" or when duplicating the layer.

     

    please fix.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2013 9:51 AM   in reply to jack_bingham

    Same issue.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 9, 2013 12:02 PM   in reply to jack_bingham

    Same issue. Not resolved in 14.1. Live shape properties CAN be accessed again with the right secret handshake: 1) create a new shape layer via copy (Cmd+J) and click on the layer thumbnail, OR select the shape using the Path Selection tool and click on the layer thumbnail. Very inefficient when you are dealing with anything more than just a few shapes.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 10, 2013 11:37 AM   in reply to jack_bingham

    They took the Live Shape Properties out completely !!  Put them back with or without bugs please.  The shape tool is usless without the Live Shape Properties!!! I'm at a stand still with my project now!!! 

     

    Please put back Live Shape Properties!!!

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 10, 2013 11:49 AM   in reply to jack_bingham

    Answer:

     

    Hollow point selector (Direct Selector Tool) will allow smart object radius options in the "Properties" window once an actual point is selected in the shape.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 10, 2013 11:52 AM   in reply to theHighestCliff

    @theHighestCliff :: They are still available for me after the recent update, though I haven't tested fto see if the bug is fixed yet (14.1)

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 10, 2013 1:55 PM   in reply to theHighestCliff

    Live Shape properties are still there, so I'm not sure what you're talking about.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 11, 2013 2:40 PM   in reply to keith_harper

    https://sphotos-a.xx.fbcdn.net/hphotos-frc3/996863_10151754854240719_844700773_n.jpg

     

    Keith has hit the nail on the head. What's the point of live shape properties if you can't access them once the document has been closed. Unless I am missing something I have this same issue, and it's infuriating. Does anyone have a fix for this, or an eta on a fix.....

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 11, 2013 2:51 PM   in reply to K Buckley

    I updated to the latest CC the other day. I have noticed the past few days I have not had the problem any more. It all works fin for me.

    I believe you have to use the select tool (A) , but make sure you have selected "Path Select" ( the black pointer with the white outline) and not "Direct Select" of the 2 options

    Then when you select  the shape, in the properties panel select the "live shapes properties" button to the left of the "mask" button at the top. I have noticed it always goes back to the mask tab, so have to always click the properties tab.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 11, 2013 2:54 PM   in reply to BunyepCreations

    Awesome! Thank you SO much, I really appreciate you taking the time to respond. The live shape properties where driving me batty.

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points