Skip navigation
Currently Being Moderated

Photoshop CC OpenCL

Jun 18, 2013 10:04 AM

Tags: #gpu #opencl

OpenCL doesn't seem to work for me. I have it checked in prefs, have the latest drivers, and a GeForce GTX 660M. Yet when I run an iris blur filter, it's extremely slow, and only uses 1 CPU. Under System Info, it lists the video card and OpenCL 1.1. Anyone else having the same problem?

 
Replies
  • Currently Being Moderated
    Jun 18, 2013 10:10 AM   in reply to mnordine

    Generally this means that you need to update your video card driver from the GPU maker's website.

     

    Also, what OS version?

    And are you using 32 bit or the 64 bit version of Photoshop?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2013 10:26 AM   in reply to mnordine

    Can you do us a favor and post your system info (PS Help > System Info...) to this thread?  We only would like to see the information leading up to the scratch disc data in that report.

     

    Thanks,

    Adam

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2013 10:38 AM   in reply to mnordine

    Thanks for posting your system info - the GPU should support OCL.  Can you do me a favor and go to Edit > Preferences > Performance... and click on the Advanced Settings button under Graphic Processor Settings?  There's a checkbox in those preferences that allows you to enable/disable OpenCL.  Is it enabled on your machine?  If not, can you enable it or is it greyed-out?

     

    My guess is that the system is using the Intel HD 4000 instead of the GeForce 660M as the primary GPU.  If you can force it to use the nVidia gpu full time, I suspect that OCL will work for PS.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2013 11:02 AM   in reply to mnordine

    If OCL is enabled in preferences then it should be in use.  My guess is the poor performance is due to the fact that both GPUs are being recognized by PS.  Have you tried disabling OCL and comparing how long it takes to do that same blur on the same image with it enabled vs disabled?  You can re-run the filter with the same settings by using cntrl-F.

     

    Is there a way for you to disable the HD 4000 gpu?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2013 11:02 AM   in reply to mnordine

    I think Adam is asking you to turn off the motherboard graphics completely in the computer BIOS.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2013 11:19 AM   in reply to mnordine

    You should be able to use Device Manager to temporarily disable the GPU.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2013 11:26 AM   in reply to mnordine

    Where do you have your monitors plugged in? Could try having nothing plugged in the motherboard video ports and all monitors (if you have more than one) plugged in the graphics card.

    I am surprised you can't switch on board graphics off in BIOS, what motherboard do you have? You don't have one of those crippled BIOS some of the big box shifters install do you?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2013 2:21 PM   in reply to mnordine

    Ah sorry I may have confused you, I had assumed you had a desktop machine not a laptop.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 19, 2013 10:23 AM   in reply to mnordine

    For Photoshop, this is the right place.

    Though it still sounds like you have some sort of driver or BIOS level problem causing OpenCL to be disabled or perform poorly (which it would on the Intel GPU).

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 19, 2013 12:54 PM   in reply to mnordine

    Then you're back to driver problems, and you need to talk to NVidia.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 15, 2013 6:53 PM   in reply to Adam Jerugim

    My "OpenCL" check box is greyed out. Also when i go to the 3D tab all the options are greyed out as well. What should I do?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 30, 2013 3:10 AM   in reply to mnordine

    I read the comments and i think you are using a MSI GE60 right? It has a GPU boost problem. So MSI published an update for this. Go MSI's website and find your product. It should be like this: http://www.msi.com/product/nb/GE60-0ND.html#/?div=BIOS&nbos=Win8 64 Read the description and update your BIOS. I hope it will help!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points