Skip navigation
Currently Being Moderated

FMS 4.5 and FMLE errors (hds-live is not defined).

Jun 19, 2013 7:15 AM

Tags: #not #live #fms #4.5 #fmle #streaming #is #"(hds-live) #defined"

I came across this thread, http://forums.adobe.com/message/4929789, because I am testing a new FMS 4.5 server and I'm having several problems with live streaming.

 

Issue 1: Server does not stream after FMLE is stopped.

I set up a test FMLE 3.2 stream last week that we hope to use for an event 4 days from now. When I initially set up the FMLE live stream everything worked fine, so I stopped the encoder and started to design a site to play the live stream. When I restarted the FMLE stream today nothing worked, and looking in the corelog I found this error: "Restarting the recording after 2.000000 days is not allowed". That error led me to the thread linked above and to several others.

 

I have tried the various suggestinons in this thread, http://forums.adobe.com/thread/959974, including:

 

Forum Post 15: changing livestream and liveevent names: changing the names works, but this is not a good solution since I am building web pages to publish these streams and that would require changing the links on the pages everytime we want to live stream.

 

Fourm Post 18. using query paramter: livestream?adbe-live-event=liveevent&adbe-record-mode=record (does not work).

 

Finally, I deleted all of the previous entries that were created in the following folder:

H:\Program Files\Adobe\Flash Media Server 4.5\applications\livepkgr\events\_definst_\

 

I restarted FMLE and the streams worked again. What can I do to fix this? As I mentioned above, using the "record" query parameter in FMLE did not work. I would hate to have to delete all of the old events every time that I want to start a new stream.

 

Issue 2: hds-live streaming does not work. I set up a multi-bit rate live streaming page following these diretions, http://help.adobe.com/en_US/flashmediaserver/devguide/WSd391de4d9c7bd6 09-52e437a812a3725dfa0-8000.html, but I cannot get hds-live streaming to work. Every connection is rejected and the edge.log file has the following error: Connection rejected by server Reason (hds-live) is not defined. I tried the suggestions posted by Manish on this thread, http://forums.adobe.com/message/4929789, (post no. 8: deleting the entries livepkgr/streams, restarting the server, clearing the browser cache), but I cannot get hds-live streaming to work. I think this problem might be related the the <MaxRestartGap> issue described above, but the steps that resolve that problem only work to enable hls-live streaming and have not solved the hds-live issues.

 

What should I do?

 

Thank you for you help.

 
Replies
  • Currently Being Moderated
    Jun 21, 2013 6:52 AM   in reply to Carlos1327

    Hi,

     

    Issue-1 : occurs if the publisher is trying to publish without absolute timestamp. Since here its FMLE, please change the <streamsynchronization> enabled to true in FMLE config.xml. And restart the FMLE.

     

    Issue-2 :  Does your Apache start without any issue? Also can you please check error.log in <AMS-Installation>/Apache2.2/logs for any errors.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points