Skip navigation
Currently Being Moderated

How to hide everything outside of the drawing area (like W in InDesign)

Jun 20, 2013 12:12 AM

I am sorry if I don't use the right words to describe everything but I have no clue what the right words are...

 

In InDesign I can press W to show or hide everything around the page I am working on. In Illustrator I can't find a similar option. I am working on something and a lot of things are outside of the actual drawing area. The problem is that I see everything all the time and so I never get a good impression of how the illustration will look when finished/printed! I now have to export a jpg in order to get a good impression! Or I have to add a layer on top of everything and place white blocks around the actual drawing area in order to get a good impression of the actual artwork.

 

There MUST be a way to show ONLY the illustration itself but I can't find it... Hope you know what I mean...

 
Replies
  • Currently Being Moderated
    Jun 20, 2013 12:44 AM   in reply to J van E

    here's a possible solution

    Artboard Preview Script

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2013 3:28 AM   in reply to J van E

    I tried this script on CC but it does not work for me.

     

    However, here is the method I usually use when all the artwork is on the same layer:

     

    Make a new square the size of the preview you want.

    In the Layers panel, hit the Make/Release Clipping Path button at the bottom of the panel.

    This masks the preview area.

    Hide or show using the eye on this sublayer.

     

    If you want to use it onwards as your work progresses, it is good to rename this sublayer and for the next preview you have to move it to the top of layer stack. Bring to Front would do the trick.

     

    A second method, if you are using many layers:

     

    Draw a rectangle which covers everything.

    Second rectange for the preview area.

    Fill both with white, no stroke.

    Make a compound Cmd/Ctrl + 8

    Move this to a new layer called Preview.

    Hide it or show using the eye on the layer.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2013 7:46 AM   in reply to Sigurdur Armannsson

    Hi Sigurdur, in a true Adobe fashion (new bugs introduced with every new release), the Script User Interface got all messed up, as reported here

    http://forums.adobe.com/thread/1235963?tstart=0

     

    try the script with an earlier version CS3-CS6

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2013 8:10 AM   in reply to CarlosCanto

    Thanks. Actually in my true fashion I thew out all previous versions of Illustrator (and CS suites) and installed CC fresh. I had preferences all the way down to CS3. But I am going to try your script on one of the other macs I have here. I have no doubts it works. Just wanted to let you know.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2013 8:21 AM   in reply to Sigurdur Armannsson

    ok, thanks for reporting that this script and most likely any other with a Script UI won't work on CC

     

    in case you get to try the script, press "Esc" to dismiss the Preview.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2013 8:29 AM   in reply to CarlosCanto

    Yes, thanks and thanks for making this script anyway. I love to use scripts (wished I could make some myself). Hope Adobe fixes this issue very, very soon.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2013 8:40 AM   in reply to CarlosCanto

    Don't know if I'm doing it wrong, but the artboard preview script works for me in CC on a Mac OS 10.6

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2013 9:18 AM   in reply to Monika Gause

    Monika, you are not doing it wrong. I was. I didn't realize that the black square on the description picture was the artboard. I thought it was a drawn square. (I am using dark for the outside area.) When I moved my objects half outside of the artboard everything behaves right.

    Sorry, Carlos, my fault. Your nice script works 100% in CC.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2013 10:50 AM   in reply to J van E

    Another old and shabby workaround is to maximise the Navigator palette while the Show Artboard Only option is turned on in its palette flyout menu.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2013 10:53 AM   in reply to Monika Gause

    thanks for chiming in Monika, then not all Script UI is broken in CC version, only some of it

     

    glad to hear at least this one script still works.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points