Skip navigation
Currently Being Moderated

Indesign CC: the shortcut «Align left --- Default: Shift+Cmd+L» seems not working...

Jun 20, 2013 2:41 AM

Under any keyboard combination: default, proper, PM, Quark

 

The Indesign label in the menu (above, left) is shadowed when the shortcut is typed.

 

 

But the rest of them are oK

Shift+Cmd+R

Shift+Cmd+C

Shift+Cmd+J

Shift+Cmd+F

 

 

Could be fixed in some way?

Just to know if it is a problem here.

CS6 was OK.

 

Mac 10.7.5

Core duo 3.06

 
Replies
  • Currently Being Moderated
    Jun 20, 2013 2:50 AM   in reply to camilo umaña

    Usually because the shortcut is assigned to something else.

     

    You can go to Edit>Keyboard Shortcuts and find the command see what it's used for - you could use the "Show Set" button and do a search to find what it's being used for.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 20, 2013 3:04 AM   in reply to camilo umaña

    I had the same problem, also when trying to centre a graphic using Shift+Cmd+E. Turns out the keyboard shortcuts in:

     

    System Preferences> Keyboard> Keyboard Shortcuts> Services

     

    now clash with Indesign. I turned them all off and now everything is fine: I never used them anyway. Keyboard shortcuts in CS6 aren't affected by this.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2013 5:58 AM   in reply to camilo umaña

    Thanks guys - great advice. InDesign CC is no behaving properly.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 25, 2013 1:01 PM   in reply to camilo umaña

    Thanks for the System Preferences fix. That worked for Left Justify. I'm also having issues with Duplicate (Cmd+Option+Shift+D). Any luck with this command?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 16, 2013 8:48 AM   in reply to Codie

    In response to your issue with the Duplicate shortcut, I disabled the Dock Hiding shortcut and that worked for me. Hope this helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 2, 2013 6:10 AM   in reply to btschmidt2338

    @btschmidt:

     

    Thx man, that helped! After disabling the dock-shortcut everything is working fine!

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 5, 2013 4:33 AM   in reply to camilo umaña

    thank you!!

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 9, 2013 9:10 PM   in reply to BrGomesCardoso

    Glad I stumbled on this, I was in the middle of a doc when all those shortcuts "suddenly" stopped working.

     

    Does anyone know if this should be fixed in a patch or if this might be a permanent behavior because CC is interacting differently?

     

    Anyway, thanks for the help!

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 9, 2013 9:43 PM   in reply to Monsieur_G

    It's not really a bug. InDesign on the Mac had to be deCarbonized and written with Cocoa calls for Mac OS X. That may be a requirement of the new programming required. InDesign just gives the system the default for keyboard shortcuts.

     

    However, it's easy to reset the system keyboard shortcuts as described above.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 9, 2013 10:20 PM   in reply to Steve Werner

    So, is that to say that similar shortcuts who once worked together (ex: hide / show dock and duplicate) won't in the future?

    Are there workarounds rather than simply reset the shortcuts? Would it be possible for the computer to recognize when InDesign is running and thus give it precedence on the shortcuts?

     

    I really don't know the inner workings of apps and such so it's a curiosity more than anything. Thanks for the info!

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 10, 2013 5:10 AM   in reply to Monsieur_G

    Maybe I didn't explain myself well. I just meant that if a shortcut is set in InDesign (e.g., Cmd+Shift+L) and is also set in the operating system (same shortcut), the OS will win. But it's easy to change shortcuts either in the OS or in InDesign to something else.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 10, 2013 6:33 AM   in reply to Steve Werner

    Actually that was a very clear explanation, what I was wondering is why (at least, to my knowledge) CS6 didn't act in the same way as CC does. The shortcuts in my OS have stayed the same and the concerned keyboard shortcuts also (e.g., Cmd+Shift+L), which is why I wondered how it would act in such a way now.

    I said it was out of curiosity as I never particularly used the OS corresponding shortcuts, so turning them off did the trick.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 10, 2013 6:44 AM   in reply to Monsieur_G

    InDesign CC was changed totally from CS 6 as it was converted from "Carbon" code to "Cocoa OS X" code.

     

    In doing so, there might have been a switch that Adobe could no longer have that lets the keyboard shortcuts take over ID.

     

    Or it might just be a bug in the conversion to Cocoa and needs to be fixed. I'm sure Adobe is aware of the situation.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2013 10:26 AM   in reply to Sandee Cohen

    I agree.  This has been bothering the hell out of me since CC arrived!  I knew that there must've been some sort of conflict somewhere, and I reported it as a bug twice.  Thankfully this thread finally showed up under a Google search for ID CC Align Text Left, after months of trying to track this down.  Hallelujah.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2013 7:00 AM   in reply to camilo umaña

    doesn't work for shortcuts like shift+F7 (align) - any solutions?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2013 7:04 AM   in reply to stijndepauw

    It's working for me on in Mac OS X 10.8.5 in InDesign CC. What operating system? What version of InDesign?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2013 7:17 AM   in reply to Steve Werner

    same system, same indd... some other keys aren't working neither... like cmd option c (adjust frame to content)

    reinstall indd?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2013 7:30 AM   in reply to stijndepauw

    Start by restoring your preferences. If that doesn't work, uninstall and reinstall.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2013 7:36 AM   in reply to Steve Werner

    I can't find a complete restore button. Where can you find this? Thanx 4 the help Steve...

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2013 7:39 AM   in reply to stijndepauw
     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points