Skip navigation
Currently Being Moderated

Broken Images - PSE 11

Jun 22, 2013 2:40 PM

Tags: #organizer #display #photoshop_elements_11 #broken_images

Why are nearly all my images broken in PSE 11 Organizer? The files are fine, just that whatever displays them in the organzer does not work correctly.

 

I just built an entirely new DB with re-organized files. Everything is all fine when I try to edit these pictures or to rotate them, say. The image appears unbroken. Nothing wrong with the data, just the display.

 

Why is this? PC/Windows 7/16 GB ram, huge amounts of disk space available. Any ideas would be appreciated.

 
Replies
  • Currently Being Moderated
    Jun 22, 2013 2:44 PM   in reply to TerryXyzzy

    Select the broken thumbnails and press F5. However, be sure you are giving PSE time to generate all the thumbnails. If you have a lot of newly-imported images, it takes a while.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 22, 2013 5:47 PM   in reply to TerryXyzzy

    For thousands of photos at once, yes, it can take all night, I'm afraid, depending on your hardware. One thing you can do that may speed up the process. Go to the organizer preferences>media analysis and be sure the auto analyzer is turned off. That greatly slows everything down when it runs.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points