Skip navigation
Currently Being Moderated

Illustrator CC Actions bug

Jun 24, 2013 6:56 PM

Tried new Illustrator CC Trial.

Loaded my Actions, saved from previous version of software.

After closing and starting Illustrator does strange things with actions:

1. It forgets all keyboard assignments to every action.

2. It forgets about certain operation each action does.

For example, i had "Flip horizontal" assigned to F4.

Program remembers the operation is held by Tranform Panel, but doesn't remember what exactly.

As the result after relaunching AICC almost every action is broken.

Same thing happens to aligning actions, make-realese mask actions, i.e. all actions based on certain operations with panels.

After reloading actions from the file everything goes back to normal but is broken again after relaunch.

Tried to recreate actions (I thought there might be difference in versions) — nothing changed.

Sync is off. PC.

Bug yet no posted to Adobe.

HALP!

 
Replies
  • Currently Being Moderated
    Jun 25, 2013 1:51 PM   in reply to achegr

    I do not use Illustrator CC. Therefore I cannot help.

     

    But I'd like to hear if some Illustrator CC user can confirm what achegr is reporting here.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2013 11:34 AM   in reply to Kurt Gold

    I just received a message that says that no AI CC user can confirm the issue.

     

    Does that apply?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2013 11:42 AM   in reply to Kurt Gold

    where's Monika when we need her? she has CC

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2013 12:26 PM   in reply to CarlosCanto

    I don't use that many actions, Carlos.

     

    Would be easiest, if achegr could post the actions he has trouble with. Or could someone else post examples of actions that might get them into trouble?

     

    I also had trouble in CS6 with an action I created in CS5. It wouldn't work at all. So actually I'm not that astonished when actions from past versions don't work.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2013 12:46 PM   in reply to CarlosCanto

    The part I think is astonishing is the line:

     

    "Tried to recreate actions (I thought there might be difference in versions) — nothing changed."

     

    To confirm that as a CC user I'd create a very simple action, assign a keyboard shortcut to it, quit and restart AI, then use the shortcut to play the action.

     

    If that would just work, then achegr has to provide more details. If it doesn't work as expected (shortcut does not work), then some more observations may be required.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2013 1:04 PM   in reply to Kurt Gold

    So...

     

    Works with one action, but not with the other. A simple one I saved from CS6 just today worked. Even the shortcut could be saved and worked in CC.

     

    An older one I saved from CS6 some months ago couldn't even be opened in CS6 anymore ... Might have been trouble in the .0 versions of CS6.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2013 1:12 PM   in reply to Monika Gause

    What does happen when you just do that in AI CC ?

     

    Create simple action in AI CC, assign shortcut, quit, restart and then play the action by hitting the shortcut.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2013 1:29 PM   in reply to Monika Gause

    thanks Monika, I was just kind of calling you, you're the only one with CC that can help.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2013 2:06 PM   in reply to Kurt Gold

    Works as well with the action I had in CC. And a shortcut.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2013 2:24 PM   in reply to Monika Gause

    Of course that's just nitpicking by me, but what does that mean?

     

    It works just as expected? Or it only works partially – as described in post 6 ?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2013 2:27 PM   in reply to Kurt Gold

    Works with an action I created in CC some days ago. I didn't experience any difficulties with shortcuts.

     

    But as far as I understood the TO, he tried to load some actions created in an earlier version. Could be interesting to dive deeper into that.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2013 4:48 PM   in reply to achegr

    https://www.dropbox.com/s/yfb3h478slvsqgu/_chegr.aia

     

    This one worked for me (Mac OS 10.6, CC)

     

    https://www.dropbox.com/s/td55yh7inkb0mto/_chegr_AICC.aia

     

    This one doesn't have shortcuts. When launched from the actions panel some work, some don't

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 28, 2013 11:37 AM   in reply to achegr

    Probably there are some other CC users who may or may not try to confirm your observations.

     

    Wait a bit.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 29, 2013 2:12 PM   in reply to Kurt Gold

    I can confirm the problem with loading actions from another version of AI. We are experiencing it across several users. The behavior is very strange and very inconsistent.

     

    We have had some success with re-recording actions in CC, but not entirely.

     

     

    AI CC seems to accept a lot of data from CS6, in terms of profile/presets, but actions just seem to fall apart.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 29, 2013 2:39 PM   in reply to Joseph Nicolia

    Importing action sets from previous versions of Illustrator has always been a delicate issue.

     

    I'm a bit more astounded about the behaviour of pure CC actions – as reported by achegr.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 29, 2013 2:43 PM   in reply to Kurt Gold

    Right- as I mentioned, we've had *some* success... Some actions refuse to function correctly when the application is loaded, unless the actions are loaded again.

     

    This is useful to keep them functional, but ultimately sub-optimal.

     

     

    Another thread has an almost identical discussion, here:
    http://forums.adobe.com/message/5427579#5427579

     

    A user on that thread notes that they got some positive results from turning off all Sync Settings in preferences.

     

    That did not work for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2013 10:09 AM   in reply to achegr

    Indeed- disabling a feature, no matter how new, is a bad idea.

     

    We're trying some additional things this week. If we have some feedback that is useful, we'll try to post here.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 10, 2013 6:22 PM   in reply to achegr

    Some machines have inexplicably stopped doing it. But otherwise, no. The actions degrade every time the application is loaded for some users.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 30, 2013 4:59 AM   in reply to achegr

    Hi

    I use Illustrator CC and have had the same problem has u have, that when i restart illustrator my actions doesn't work and particular line size.

    But i have learned to reset my saved actions and then load it again, and then it works..damn annoying to have to do that every day but it works for me...for now!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 11, 2014 3:56 PM   in reply to achegr

    Funny, I started a thread on this very issue last week. Seems after restarting the Program Illustrator forgets certain actions. like Attribute Setting for an object being manipulated with the action just goes away. I can reload the actions fresh each time I start Illustrator and this seems to work. I have reported this as a BUG. I can't recreated it on another machine but it is not working correctly on mine.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 11, 2014 4:04 PM   in reply to Monika Gause

    When you say it worked for you are you doing what he is sighting as the issue. I can load the actions anew and they work but as soon as I quit AI and launch the program again it will break the actions. Adobe has never been able to keep a script in an action after relaunching the program but now this has taken it from bad to worse.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 11, 2014 4:06 PM   in reply to Kurt Gold

    Yes, confirmed. Same issue here. Any solutions? I'm not seeing any yet.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 11, 2014 4:08 PM   in reply to PrepressPro1

    Leave the Default Actions loaded. It doesn't resolve the issue at large, but it's a fine workaround, for now.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points