Skip navigation
VNemo
Currently Being Moderated

Create-Item stored procedure return error for hte parameter

Jun 25, 2013 6:57 AM

Tags: #adobe #flex #adep #data_services

Hi,

 

I'm getting the following error when I create an item with the data services:

 

INFO: [Data Services] [DEBUG] SQL Assembler jdbc exception on operation=create-item error=com.microsoft.sqlserver.jdbc.SQLServerException: The value is not set for the parameter number 1.

    at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDriverError(S QLServerException.java:190

 

Configuration settings are:

 

      <source>flex.data.assemblers.SQLAssembler</source>

      <scope>application</scope>

      <metadata>

        <identity property="TO_ID" undefined-value="0" />

      </metadata>

 

        <create-item>

          <procedure name="spMob_TakeOff_Details_Header_Insert">

            <procedure-param property-value="#ID#" type="OUT"/>

            <procedure-param property-value="#Session_ID#" />

            <procedure-param property-value="#Notes#" />

          </procedure>

        </create-item>

 

ID always has value equal to 0, and this procedure always falls.

Could anyone help or explain to fix this?

Could this be bug of JDBC (https://bugs.eclipse.org/bugs/show_bug.cgi?id=385627)?

 

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points