Skip navigation
Currently Being Moderated

Swipe left and swipe right not 'sticky' enough in DPS

Jun 27, 2013 1:48 PM

I've found that when using the Swipe left and Swipe right function in tandem with DPS, the swiping action swipes away from the page. Any way to make the action 'stickier' so that it actually does what the action is set up to do and not swipe away from the page?

 

Thanks

 
Replies
  • Currently Being Moderated
    Jun 27, 2013 5:24 PM   in reply to i.brown33

    Hey, i.brown-

     

    It sounds like you're trying to use swipe events and the content viewer is interpreting that as going to the next page.  It seems like this is a problem that would be generic to all placed objects, so I'm moving this over to the DPS forum for the experts there to answer.

     

    Thanks,

     

    -Elaine

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 27, 2013 8:47 PM   in reply to elainefinnell

    What do you mean by "swipe left" and "swipe right" functions?

     

    Neil

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 28, 2013 10:16 AM   in reply to Neil Enns - Adobe

    Hey, Neil-

     

    As Ian posted, swipeleft and swiperight are jQuery/HTML events that we support within Animate.

     

    -Elaine

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 29, 2013 1:33 PM   in reply to i.brown33

    you dont say whether you are using .OAM or using a web view with the html file.

    If web view, have you checked allow user interaction, sorry if thats a basic question, but if not checked the page will swipe, not the EA content

    Have you tried importing both the html and oam, just to see which works best.

    Are you testing on device, or on the desktop viewer?

     

    cheers

    Alistair

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2013 7:46 AM   in reply to i.brown33

    Hi there

    You havent really described point by point what is happening or not as the case may be.(other than DPS is swiping to a new page)

    have you tested the html file together with the swipe, actually works outside of DPS?  - sorry to ask but you dont actually say.

    Personally I've found the swipe to be quite clunky, not at all smoothe, but I know the Adobe team are now on holiday, so we probably wont get too much response from them at the moment.

    Happy to look ate you file if you want a 2nd opinion

     

    Cheers

    Alistair

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2013 8:04 AM   in reply to i.brown33

    ah, OK...

    so it actually sounds that the swipe is working, and I fear that its just the poor performance of the swipe that is causing an issue with DPS, as the DPS pages also swipe, there could be a conflict. I doubt there will be a quick or simple fix to this. But I'm no expert, and I think we may just have to wait for some Adobe feedback!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2013 10:16 AM   in reply to i.brown33

    I've got the exact same problem happening on my end. The swipe plays but, at the same time, grabs the page to pull it to the next article. very frustrating. I will let you know if I find a fix.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points