Skip navigation
MichaelDavidL
Currently Being Moderated

Problem rendering shadows with Firefox PDF plugin

Jul 2, 2013 8:11 AM

Tags: #pdf #export #cs6

When I add shadowing to pictures and text in InDesign and export to a PDF, the PDF reader in Firefox fails to render the shadows correctly. It renders them as black boxes rather than gradients. Here is a sample export of a photo that I shadowed in InDesign...

ShadowedPictureInFirefox.jpg

I've only found Firefox to be the problem. In the PDF readers I have this same PDF displays fine. The PDF reader for Chrome, and Internet Explorer display fine as well. Here's how the same PDF exported from InDesign appears with other browsers/readers...

ShadowedPictureInChrome.jpgI am posting a newsletter with shadowing to our website, so I would like the display of shadowing to work in all browsers. Any way to export the PDF from InDesign without displaying black boxes in Firefox?

 

If all else fails, I am thinking I may have to remove the shadowing from the PDF version of our newsletter... but I would really prefer to keep the shadowing. Any ideas/suggestions?

 
Replies
  • Currently Being Moderated
    Jul 2, 2013 8:19 AM   in reply to MichaelDavidL

    Firefoxes PDF viewer is pretty lousy

     

    Go to Tools>Options>Application and scroll down to Portable Document Format (PDF) and switch it to use Acrobat instead of Firefox PDF reader.

     

    And send those instructions out to your clients too.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 2, 2013 8:22 AM   in reply to MichaelDavidL

    I'd also suggest you get in touch with Mozilla themselves so they can release a fix for the problem. You can find twitter and facebook feeds as well as direct contact through their website.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 2, 2013 8:33 AM   in reply to MichaelDavidL

    However, (a last resort if all other things will fail), what you can try is to "simulate overprint" at output stage.

    This will flatten the whole thing.
    This option is available, if you output to EPS or PS (InDesign or AcrobatPro). Then you could redestill to PDF.
    Only recommended for a special purpose like yours.

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 2, 2013 8:40 AM   in reply to Laubender

    Or just make a JPEG of it and put that up

     
    |
    Mark as:
  • Rob Day
    3,120 posts
    Oct 16, 2007
    Currently Being Moderated
    Jul 2, 2013 12:14 PM   in reply to MichaelDavidL

    When you export force the PDF to flatten—set Compatability to Acrobat 4 (PDF 1.3).

     

    this flattened PDF works in my FF:

    http://www.zenodesign.com/forum/dsflat.pdf

     

    while the same page exported with live transparency does not, PDF/X-4 in this case:

     

    http://www.zenodesign.com/forum/dsx-4.pdf

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 2, 2013 1:21 PM   in reply to Rob Day

    @Rob – flattening alone might not be enough in some cases. ;-)

     

    You have to make absolutely sure that there are no overprinting elements.
    Thus my recommendation: "Simulate Overprint" at output stage…

     

    Uwe

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 2, 2013 1:41 PM   in reply to MichaelDavidL

    Is there a better workflow than this?

     

    @Michael – you could print to a PostScript* file (*.ps) out of InDesign (Composite-CMYK) and check "Simulate Overprint". Afterwards distill the PS file to PDF with Adobe Distiller that comes along with Adobe Acrobat Pro.

     

    * To be able to do this:
    On Mac OSX you need the "ADPDF9.PPD" file and you have to put it in a new folder named exactly "PPDs" (without quotation marks) in the "Presets" folder of your Adobe InDesign program folder (InDesign CS5, CS5.5 and CS6).

     

    Restart InDesign and go to the print dialog.

    Choose "PostScript File" for Printer.
    Choose "ADPDF9.PPD" for PPD.

    In the Output pane:

     

    For "Color" choose "Composite CMYK".
    Check "Simulate Overprint" in the lower region of the menu.

     

    All other settings should be self-explanatory…
    (like flattening transparency etc.)

    If not, ask here again.

     

    Uwe

     
    |
    Mark as:
  • Rob Day
    3,120 posts
    Oct 16, 2007
    Currently Being Moderated
    Jul 2, 2013 2:25 PM   in reply to Laubender

    You have to make absolutely sure that there are no overprinting elements.

    Thus my recommendation: "Simulate Overprint" at output stage…

     

    Just convert to RGB on export. So on this PDF'd page the orange (Patone spot) and black (CMYK) are set to overprint the cyan box (CMYK) with shadow. If I set the ID export output to this:

     

    Screen Shot 2013-07-02 at 4.48.16 PM.png

     

    I get this PDF which still is working in my FF:

     

    http://www.zenodesign.com/forum/rgb.pdf

     

     

     

    Screen Shot 2013-07-02 at 5.24.24 PM.png

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 2, 2013 2:54 PM   in reply to Rob Day

    @Rob – ah, allright.

     

    And "Simulate Overprint" as option is also present in PDF Export (but of course [EDIT] not setting the export to PDF/X). You need that, too in case…

     


    Example:

    InDesign

     

     

    InDesign_RectangleIsSetToOverprint.png

     

    Exported to PDF with Comp sRGB. "Simulate Overprint" not checked in PDF Export:

     

    PDFExport_SimulateOverprinting_NO.png

     

    Exported to PDF with Comp sRGB. "Simulate Overprint" is checked in PDF Export:

     

    PDFExport_SimulateOverprinting_YES.png

    So, the best workflow for Michael would be Export PDF from InDesign with your settings plus "Simulate Overprint" checked.


    Uwe

     

    Message was edited by: Laubender Added the important word "not"!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points