Skip navigation
Currently Being Moderated

Problems with Photoshop CC 3D Text

Jul 9, 2013 12:44 PM

     Recently, I got Photoshop CC. I started exploring the new features, and they're great! But when I tried to make 3D text, I couldn't do it... There was no 3D button/option. Is this a bug? If it is, how do I fix it? If not, why don't I have it, and what can I do to get it? I have Photoshop CS6 Extended, which allows me to create 3D text. I'm hoping I don't have to switch between versions every time I want to make 3D text...

Also, one more thing. When I first launched Photoshop CC, it said "Would you like to migrate your presets from Photoshop CS6?" I chose No, because I had no idea what this would do, since I'm not the most experienced Photoshop user. I hope this didn't cause my problem.

 

Thanks,

Charchar712

 
Replies
  • Currently Being Moderated
    Jul 9, 2013 5:45 PM   in reply to charchar712

    Hi,

     

    Not migrating the presets should have no impact for your case.

     

    What OS are you using? And which version of Ps CS6 do you have (13.0.5, or 13.1.2)? Does your video card have 512MB VRAM? You can check that by going to Help> System Info... and looking down the list for 'Video Card Memory:'

     

    Make sure you are using an RGB document too.

     

    regards,

    steve

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 10, 2013 12:53 PM   in reply to charchar712

    Hi,

     

    Ps CC is version 14.0.0. Launch the application and then go to Help> System Info... from the application menus. I believe the AMD A8 is a CPU that you can pair with a discrete GPU. Do you have a link to the ASUS model with tech specs.?

     

    Are you able to get Ps CS6 to generate 3D layers on the same machine? If so, then it is likely that the video card (or driver) is reporting less than 512 MB VRAM.

     

    regards,

    steve

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 10, 2013 2:26 PM   in reply to charchar712

    Hi,

     

    Can you go to your preferences and let me know if the 3D section is active? Does the Total Available VRAM show 512MB?

     

    Screen Shot 2013-07-10 at 2.24.50 PM.png

    thx,

    steve

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 10, 2013 9:49 PM   in reply to charchar712

    Hi,

     

    Is that pref. diaolog from Ps CC or Ps CS6? I'm as baffled as you that 3D is missing. You're screenshot looks like what Ps CS6 non-extended would show.

     

    I'm hoping to have an AMD A10 system with Win 8 to take a look at tomorrow. I'll let you know what I find. Do you know if there are any newer drivers for your machine to fix any Win8 issues?

     

    regards,

    steve

     
    |
    Mark as:
  • Noel Carboni
    23,455 posts
    Dec 23, 2006
    Currently Being Moderated
    Jul 10, 2013 10:41 PM   in reply to SG...

    Steve!  You don't recognize the off-center, more teal-colored [Ps] CC 14.0 icon? 

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,455 posts
    Dec 23, 2006
    Currently Being Moderated
    Jul 10, 2013 10:41 PM   in reply to charchar712

    Sorry, I had missed that.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 13, 2013 12:41 AM   in reply to Noel Carboni

    Hi,

     

    So I have a very similar AMD APU with Radeon HD 7620G and the same driver version. I get the 3D features active and working for Ps CC. OS is also Win8 x64.

     

    Did you install the app using the CC desktop app, or did you get it via direct link?

     

    It appears to be acting like the Ps non-Extended version.

     

    regards,

    steve

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 19, 2013 6:11 PM   in reply to charchar712

    Hi,

     

    So far it does appear you're not going anywhere with 3D in Ps CC. I'm still not sure why. I'll keep trying to track down suggestions for you next week.

     

    regards,

    steve

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 21, 2013 7:08 AM   in reply to charchar712

    I am having the same problem please postt if u have found the solution

     
    |
    Mark as:
  • Noel Carboni
    23,455 posts
    Dec 23, 2006
    Currently Being Moderated
    Jul 21, 2013 8:27 AM   in reply to charchar712

    Have you tried really basic restorative remedies, such as clearing the Photoshop preferences to defaults, and even uninstalling and reinstalling the software?

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 21, 2013 11:07 AM   in reply to Noel Carboni

    reinstalled did not work even deleted prefrences when uninstalling

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 21, 2013 8:50 PM   in reply to charchar712

    I have the exact same problem except that I have OS X Mountain Lion and I am on a 27" late 2012 iMac!
    I am using Photoshop CC 12.0
    And my graphics card (GTX 660m has 512mb of memory)
    I am really disapointed that I'm unable to use the 3D function of CC

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 27, 2013 3:36 PM   in reply to ProDesigneHd

    Photoshop CC is version 14.0.

     

    Photoshop 12.0 is CS5.

     

    Which one do you really have?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 2, 2013 5:13 AM   in reply to Chris Cox

    Sorry, but i'm having the same problem, but I have the 3D Button and 3D Options activated and I still having the same problem! Can't make  nothing in 3D, My Display drivers are updated from official Intel Website and I have 2763 Vdram dedicated to 3D!1.jpg2.jpg3.1.jpg4.jpg

     
    |
    Mark as:
  • Noel Carboni
    23,455 posts
    Dec 23, 2006
    Currently Being Moderated
    Sep 2, 2013 1:17 PM   in reply to (Wako)

    You put all that effort into capturing the various settings, why not capture the error as it happens as well?  "Can't make nothing in 3D" doesn't tell anyone much about what might be going wrong.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 2, 2013 9:14 PM   in reply to Noel Carboni

    I'm sorry, I Had thought had uploaded this picture!!! This is the error! 5.png

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 2, 2013 10:28 PM   in reply to (Wako)

    Your video card driver is returning an error - just like the dialog says.

    Talk to Intel about why the driver is returning an error.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 3, 2013 3:44 AM   in reply to Chris Cox

    Alright, thankyou!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 30, 2013 11:54 AM   in reply to charchar712

    I notice that Wako's  document is in RGB Colour Mode, but just to clarify something.
    3D Text will not work if you've created your document in a CMYK colour gamut.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 1, 2013 6:52 AM   in reply to Ranjoharbri

    Hello,

    I've the same 3D compatability issue. It doesn't show up on the tabs. My vram is 1024 mb and i use the adobe photoshop cc 64 bit with windows 7 ultimate 4 GB ram and all matching criteria for the software. I badly need this 3d button. And am using it in RGB mode only, still not working! Please help. Thank you.screenshot.jpg

     
    |
    Mark as:
  • Noel Carboni
    23,455 posts
    Dec 23, 2006
    Currently Being Moderated
    Dec 3, 2013 5:32 AM   in reply to senti_freaky

    Senti_freaky, your display driver is dated 2011 - that is woefully out of date.  You'll need to visit nVidia.com and download a fresh release.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 15, 2013 6:20 AM   in reply to Noel Carboni

    Thanks Noel for your reply! But the problem persists even after the update! please help...ss2.jpg

     
    |
    Mark as:
  • JJMack
    5,977 posts
    Jan 9, 2006
    Currently Being Moderated
    Dec 15, 2013 8:26 AM   in reply to senti_freaky

    From what I can see you have two graphics cards installed which are not the same.  Adode Photoshop has a problem with a configuration like that.

     

    http://helpx.adobe.com/photoshop/kb/photoshop-cs6-gpu-faq1.html

     

     

    Are you using more than one video card?

     

    #

    Multiple video adapters can cause problems with GPU-accelerated or enabled features in Photoshop. It's best to connect two (or more) monitors into one video adapter. If you have to use more than one video adapter, make sure that they are the same make and model.
    Otherwise, crashes and other problems can occur in Photoshop.

    Note: Using more than one video adapter does not enhance Photoshop's performance.

     

     
    |
    Mark as:
  • Noel Carboni
    23,455 posts
    Dec 23, 2006
    Currently Being Moderated
    Dec 15, 2013 8:13 AM   in reply to senti_freaky

    Many folks don't realize they don't need more than one video card to drive more than one monitor.  Modern cards can often drive 3 or more monitors.  If it's possible, disable the Intel interface and reconfigure your system to use just the nVidia card.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 18, 2013 6:37 AM   in reply to Noel Carboni

    Oh that's a new lesson for me!! Thanks JJMack and Noel for it.. But now i've problems with changing the display driver. My default driver is intel hd 3000 and when i tried uninstalling it it goes back to standard vga display only and i dont know how to make my nvidia driver(nVidia GT Geforce 520 MX) as the default driver. I tried searching for an answer but couldn't find a solution! Please help with that... Thank you!

     
    |
    Mark as:
  • JJMack
    5,977 posts
    Jan 9, 2006
    Currently Being Moderated
    Dec 18, 2013 11:02 AM   in reply to senti_freaky

    I have never had two display adapters in a machine or run Windows 8.  What I would try on your system would be to get into the device manager and then expand your display adapters the right click on the intell display adapter on click on Disable.  Shutdown. Hook both displays the the Nvidia adapter and boot.

    Capture.jpg

     
    |
    Mark as:
  • Trevor Dennis
    5,829 posts
    May 24, 2010
    Currently Being Moderated
    Dec 18, 2013 12:44 PM   in reply to senti_freaky

    senti_freaky wrote:

     

    My default driver is intel hd 3000 and when i tried uninstalling it it goes back to standard vga display only and i dont know how to make my nvidia driver(nVidia GT Geforce 520 MX) as the default driver. I tried searching for an answer but couldn't find a solution! Please help with that... Thank you!

     

    The VGA display thing is exactly what you would expect to happen if you remove your videi card driver.   I haven't read the whole thread, but unless there is some very special reason, you need to update the driver.  Not remove and replace.

     

    Go to the nVidia site and take it from there

     

    http://www.nvidia.com/Download/index.aspx?lang=en-us

     
    |
    Mark as:
  • Noel Carboni
    23,455 posts
    Dec 23, 2006
    Currently Being Moderated
    Dec 18, 2013 2:33 PM   in reply to senti_freaky

    You'll need to plug your monitors into the nVidia card.  I'm sorry for any miscue; a nVidia driver can't operate an Intel interface.  The intent is not to have two interfaces.

     

    I don't know your particular hardware.  Do you have the ability to drive all your monitors from the nVidia card?

     

    If so, is the Intel adapter in your machine on the motherboard?  If so, there may be a way to disable it entirely via BIOS settings.  That would be the best approach.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 21, 2014 12:50 PM   in reply to Noel Carboni

    I am having the SAME problem! I have Adobe Photoshop CC (v14) and I HAVE used the 3D mode on the same build before! I changed no settings, and now it is not working... Any help?

     

    System Info: https://pastebin.com/upTVT8Mr

     

    My Components: http://pcpartpicker.com/user/ZakyyyHD/saved/3j5M

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points