Skip navigation
rhadley007
Currently Being Moderated

Adobe Lightroom 5

Jul 9, 2013 7:56 PM

I purchased Adobe lightroom 5 and want to download it. When I click on the download button a message pops up saying I need to use a supported browser. How can I get the correct browser to start the download?

 
Replies
  • Currently Being Moderated
    Jul 9, 2013 8:27 PM   in reply to rhadley007

    At a guess you're probably using IE10. Issues like this are frequently reported in these forums in relation to IE10. Adobe's website seems to think IE10 is IE1 (ancient and outdated) and launches the error message.

     

    Either use Compatibility View in IE10 so that Adobe's website thinks it is IE9.

     

    Or simply use a different browser (e.g. Chrome or Firefox)

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points