Skip navigation
Currently Being Moderated

LR5: Odd Behavior/Bugs When Rating & Flagging

Jul 10, 2013 4:03 PM

Tags: #bug #rating #keywording #flagging #lr5 #rejecting

So, while I've very much enjoyed the new features in LR5, I've been struggling with a few bugs that seem to keep popping up again and again.  I'm not sure that anyone has reported these exact bugs yet, though, so I'm wondering if this is happening to anybody else or if there's just something odd going on with my install.

 

Everytime I start up LR5, things like flagging, rating and keywording work fine in both the library and develop module.  When a single photo is selected, these settings are applied to that photo.  When multiple photos are selected with auto-sync on, the settings are applied to each photo properly.  So far, so good.

 

But at some random point during every session, LR5 spontaneously starts going haywire and develops a few odd and extremely aggravating behaviors.  Here are a few examples:

 

  1. I might hit the "3" key to give the selected photo a 3-star rating.  The quick notification will appear that confirms the operation, but then nothing happens to the photo... the rating doesn't appear.  Once that happens just once, the rating functionality using the keyboard is totally broken and will simply not work.  I can hit "2" and then "1" and then "4" and so on and so on, and the notification confirming my rating pops up, but the photo's rating never actually changes.  However, if I choose the rating from the right-click context menu, the rating will usually work even after the keyboard-activated rating behavior is broken.  Upon restart, the problem goes away.
  2. Same as #1, but with flagging/rejecting.
  3. Occasionally, I've been rating single images one after another.  All of the sudden, I'll give a certain image a rating and that rating is instantly applied to every photo in the folder, even though only one image is selected.  This, of course, effectively obliterates every prior rating I made in that folder, which is really disheartening... especially when I had gotten through 100 or 200 photos already and now every photo is suddenly set to 3-stars, or whatever the case may be.  Undo doesn't seem to fix the issue either.
  4. Same thing as #2, but happens when flagging or rejecting.  Everything will be working fine, but suddenly I will flag a certain photo or set a certain photo as rejected, and every photo in the folder gets the same treatment.
  5. Same as above, but with keywording.  For instance, I might multi-select 5 photos and apply the keyword "forest".  All good.  I can continue that way for a while, but at some point inevtiably, I will multi-select and try to add a keyword like "water", but it won't be applied to any of the images.  From that point on, until I restart LR5, keywording literally just stops working.  I can single or multi-select, write in one or more keywords... but nothing actually gets committed to the images.  Alternatively, sometimes I select a single photo and add a keyword, but somehow the keyword gets applied to every photo in the folder instead.

Other background information:

  • Many of these bugs can occur in combination, and usually do.  So once LR5 breaks and all these bugs start occurring, I have no choice but to restart. 
  • When I restart Lightroom, these problems cease temporarily.  The photos upon which I was working when the error occurred are suddenly able to be rated, flagged and keyworded as normal with no unexpected behaviors, so it's unlikely to be an issue with the image files themselves.

I hope I explained these bugs well enough.  The problem is so perplexing -and seems to occur so randomly- that at first I actually gave LR5 the benefit of the doubt and just chocked it up to one-off glitches that would probably not happen again.  I'd restart LR5 and everything would work properly... that is, until it would happen all over again.  As it stands now, I end up having to restart Lightroom at least twice in a one or two hour editing session.  So, suffice to say, these bugs are occurring quite frequently.

 

Furthermore, in one instance I overwrote every rating and every flag/reject setting on over 1000 photos when LR5 decided to apply my flag and rating from a single photo to the entire collection in which it was contained.  Undo had no idea that LR5 applied these settings to every other photo, so it obviously couldn't undo the operation.  THAT was a seriously demoralizing instance of the bugs... one which I'm very nervous about repeating as I continue to develop more photos in my backlog.

 

I suppose that what is baffling me is that I haven't really seen anybody discuss this particular type of bug in LR5.  GIven that the bug either A) makes rating, flagging, keywording impossible until LR5 is restarted, or B) overwrites every rating, flag setting or keyword in the current folder... I would think this would be on the LR5 "hot issue" list by now.  That's why I'm beginning to think it might be a series of problems occuring mostly just on my install for some reason.

 

Anyone else notice these problems?

 
Replies
  • Currently Being Moderated
    Sep 18, 2013 7:00 AM   in reply to JG_Coleman

    I'm having this happen as well... but I'm on a Mac so the help article was no help...

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 25, 2013 6:41 PM   in reply to JG_Coleman

    I've been having a similar problem. I've flagged and rated the same set of images 3 times now, and every time I bring them up again, the ratings are gone and I have to start over. With 700+ images in this photoshoot, I'd like to get to actually editing the photos!  I will try the fix mentioned by JG-Coleman - hopefully that will solve this as well.  All these glitches make the program very difficult to learn. Wondering if it's worth the trouble.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 25, 2013 6:58 PM   in reply to CarolPhillips

    Some of these bugs are fixed in latest version - do try it if you're not already running it.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 28, 2014 5:12 AM   in reply to Rob Cole
    I am running
                    Lightroom 5.3/Adobe Camera Raw 8.3

     

    and I am experiencing these kinds of problems on a sporatic basis. The latest was two days ago when I would press 8 and get a message "Setting filter to green" but it wouldn't change the flag color or come up when I filtered by green. I tried this several times without success. Then I restarted Lightroom and it worked fine. I have experienced quite a numbe of situations where Lightroom stopped behaving as I have come to expect and restarting it was the only way I have found to get it to return to normal behavior.

     

    I am assuming the the ui.dll that is linked to above is included in version 5.3. Am I correct?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 9, 2014 2:07 PM   in reply to florida_guy

    I'm having the same issue.

     

    I did a DOS file compare between the file contained in the patch and the one installed on my system (Ver 5.3). The dates and files size are different. The date one on the file on my system is newer. Unfortunately it matches the date I did the upgrade to 5.3 thus I can't tell if the file in the patch is newer or older than that supplied with the upgrade. I don't won't to apply the patch until I find out if it relates to our version of LR.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2014 5:56 PM   in reply to JG_Coleman

    I'm on Windows 7 x64 and LR 5.3 and also have the issues described in the original post, aside from item 3 which I have not experienced.  I am also unwilling to apply the patched ui.dll described above, since the article at the provided link is not dated and does not describe which  version of LR5 it can be applied to, and the description of the issue ("Lightoom 5 crashes when you rate, label, or flag your image") does not give enough detail to know whether it applies to this issue.  In my case and the ones described above, LR continues to run, but the rating mechanism is broken.  I don't know if that qualifies as "crashes".  I did download the ui.dll file and it is different (in size) from the one included with LR5.3, but until Adobe provides more specifics in the article, I'm unwilling to install it.  This problem has been around since at least July 2013, so it should be time for an official fix.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2014 6:19 AM   in reply to Roger Cornelius

    Upon starting LR this morning I was greeted with a message indicating an upgrde to V5.4 is availalbe. I have DLed the upgrade and will apply it later today. Let's hope this issue has been fixed.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points