Skip navigation
heartsanddeath
Currently Being Moderated

When copying a state, symbols get lost (latest CS6 Update)

Jul 11, 2013 12:40 AM

Tags: #cs6 #symbols #copying #states #copying_states

This is driving me absolutely NUTS. I'm working in Fireworks on a daily basis and I use symbols a lot. But ever since the last update for Fireworks CS6, every time I copy a state, it doesn't copy the symbols as well.

 

If the symbol is grouped (whether with other elements, or not), the symbol gets copied.

 

It's been a pain these past days to work around this issue. But when searching the forums, I discovered that nobody else seems to have this problem, so maybe I did something wrong? Can anyone help?

 
Replies
  • Currently Being Moderated
    Jul 15, 2013 11:35 PM   in reply to heartsanddeath

    Same issue here.  I actually didn't realize that it was a symbol issue until I read your post.  Had to share my layers across states but that's not really what I need.  I doubt there's a fix coming from Adobe any time soon, but fingers crossed.  Didn't have this issue with CS6 I had on another machine.  For now I'll just use your workaround of grouping the symbol.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 23, 2013 1:07 AM   in reply to heartsanddeath

    I have the same issue as well. Adobe not only didn't fix the memory bug, they introduced new ones!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 12, 2013 1:45 AM   in reply to heartsanddeath

    Me and my colleague got the same issue. Happened to us after the Fireworks latest update. Reinstalling Fireworks and not applying the latest update (which is kinda paradox) solved the problem for us. Hope this helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 25, 2013 6:47 AM   in reply to heartsanddeath

    you have to convert the image to symbol and the select button ,after that you click twice on it and then select the state here http://prntscr.com/1tdms1

    not here

    http://prntscr.com/1tdmx8

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 25, 2013 6:18 PM   in reply to heartsanddeath

    I was experiencing this same issue.  I found a work around by deleting and rebuilding the Fireworks preferences file using the knowledgebase article below. After restarting Fireworks I was able to duplicate states with all symbols being copied accross.  I hope this works for you guys too!

     

    http://helpx.adobe.com/fireworks/kb/restore-preferences-fireworks-cs5. html

     

    Cheers,

     

    Greg

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 25, 2013 7:21 PM   in reply to BigQuiver

    Check that...  When I retested it I duplicated a page accidentally rather than a state.  Duplicating states still does not work.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 6, 2014 5:14 PM   in reply to heartsanddeath

    I'm experiencing the same problem. Has anyone found a workaround so that duplicating a state doesn't delete all symbols in the duplicated version? I spend my day duplicating symbols, so this has become a serious problem...

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2014 11:32 PM   in reply to heartsanddeath

    Hi all.

     

    Yesterday, I received a request from Chad Thornton at Airbnb to create a command to fix this issue.

     

    Luckily, the answer was easy to find and it works like a charm.

     

    Download this command https://www.dropbox.com/s/z22ov4vom02w311/Duplicate%20State.jsf and put it somewhere in your 'Commands' folder.

     

    Now, whenever you want to duplicate a state, use the command instead of the States panel menu, and all symbols will be there : )

     

    Enjoy!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 13, 2014 1:00 AM   in reply to heartsanddeath

    Honestly, I don't use states that much, so I haven't tested the command a lot and I'm sure there are more bugs lurking there.

     

    I'm currently working on fixing it for the case where some elements are locked. Is this the case in your document?

     

    If not, would you mind sharing a document where it doesn't work, so I can reproduce the bug on my side?

     

    Thanks in advance! : )

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 13, 2014 2:32 AM   in reply to heartsanddeath

    Cool!

     

    I hope to have a version that works with locked elements ready soon. I'll post it here when it's done.

     

    Glad to be of help!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 13, 2014 3:54 AM   in reply to heartsanddeath

    Ok, here it is: https://www.dropbox.com/s/z22ov4vom02w311/Duplicate%20State.jsf

     

    It should work with locked elements. However, the locked status of elements is not carried over to the new state. I might try to fix that later on, but it looks quite hard and I honestly don't see the benefits to make it worth pursuing : )

     

    Let me know how it works!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points