Skip navigation
cholden1
Currently Being Moderated

DW CC DB Connection failure

Jul 16, 2013 3:11 PM

Tags: #error #dreamweaver #mysql #404 #database_connection #cc

I'm using DW CC,  installed the deprecated DB functionality (yes, I know!) . I'm not able to successfully connect to the DB I created on my remote server.

 

Error msg:  HTTP error code 404.  The testing server specified for this site does not map to the www.uglypals.com/_mmServerScripts/MMHTTPDB.php. I don't have a testing server set up and am using my remote server for testing, which is essentially a throw away site where I'm trying some new things. My ftp works fine and, up until now, I've just been testing off the remote server.

 

Here's the connection.php code:  (names / pswd changed to protect the innocent:))

 

<?php

# FileName="Connection_php_mysql.htm"

# Type="MYSQL"

# HTTP="true"

$hostname_htsConnection = "localhost";

$database_htsConnection = "db name";

$username_htsConnection = "my user name";

$password_htsConnection = "my password";

$htsConnection = mysql_pconnect($hostname_htsConnection, $username_htsConnection, $password_htsConnection) or trigger_error(mysql_error(),E_USER_ERROR);

?>

 

I've given access permission for my computer to access the DBs remotely. 

 

Hosting support sent me a dialogue box into which I entered exactly the same information as I entered in the DW connection set up dialogue box. SInce I can connect and they can connect via their script, they are done.   I'm not sure where the problem lies in concatenating the -mmServerScripts.....to www.uglypals.com.....DW or the hoster. This seems to be the problem but, at this point, I'm just plain lost as to what to try next. In pouring thru DW help I found this little ditty: 

'"Dreamweaver makes a best guess at auto-populating the value for the URL prefix in the Testing Server category of the Site Definition dialog box, but sometimes you will have to adjust the URL prefix to get your connection to work. Make sure that the URL prefix is the URL that users type in their browsers to open the web application, minus the file name (or start page) of the application."

 

The testing server URL = http://www.uglypals.com/.  In my case, the remote and testing servers are the same at this time. Generally, I do work on a local server (WAMP) but it shouldn't make any difference, correct?

 

Any help is very much appreciated! Yes, I'm still fairly new at this and still learning, but I've done this before without any problems, but with another hoster. I may not be asking my hoster the right questions which is why I'm not getting answers but I can't be the first person who is having this issue.

 
Replies
  • Currently Being Moderated
    Jul 17, 2013 8:25 AM   in reply to cholden1

    Hi Colden1,

     

    Did you tried copying the "_mmServerScripts" folder to the root folder of site on the remote/testing server from the local site folder.

     

    Have a look at the video http://www.youtube.com/watch?feature=player_embedded&v=cB2vmNfcq7A

     

    Thanks

    Bhawna

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2013 2:34 PM   in reply to bgupta16

    Thanks for the suggestion.  I checked and the _mmServerScripts folder is in the root folder. It's an empty folder. Is that correct?  It's an add-on doman andit  is the first folder listed in the root directory for the add-on domain.  I had watched the video but, since I'm not using a local server like WAMP I didn't copy the MMHTTPDB.php and mysql.php files to the connection folder on my local server as suggested in the video. I did copy these files to the connections folder and ftp'd them to the remote server but still no DB connection.  Sorry I'm a litle slow on the uptake here, but I'm learning by doing which is to say THE HARD WAY! Thanks for your help!

     

    I may just move back to DW CS6 until DW CC decides if and how they will support DB services and see if I can get my DB connection to work.  My gut instincts tell me that the problem lies not with DW but with the hoster so I'll keep bugging them until I find someone with, shall we say, more experience. Needless to say, I'm at a standstill until I can figure this out.

     

    Thanks for reaching out to help! I really appreciate it!

     

    Cheryl

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 17, 2013 2:47 PM   in reply to bgupta16

    The DB connection works like a charm using DW CS6 so I'll just go with that for now.  I must be missing something when watching the ''How to Use the Server Behaviors extension to enable Server Behaviors in DW CC''. I'll keep trying as there is probably something to learn there.  Again, thanks for taking the time to help!

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 18, 2013 12:58 AM   in reply to cholden2

    Copying the files "MMHTTPDB.php" and "mysql.php" into _mmServerScripts folder on the remote server should work..May be you can try doing a test by creating a new site and database just to make sure if its working in DW CC..

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2013 8:55 AM   in reply to cholden1

    Had the same problem. Basically, after installing the missing panels (Bindings, Database and Server Behaviors), I was able to see existing bindings on website created with (the wonderful) Dreamweaver CS6, but unable to edit or create a recordset. DW CC was simply unable to find/create a binding with the database. Behind the hood : it creates the folder "_mmServerScripts", but can't create the two required files inside it.

    Of course copying and pasting existing  files "MMHTTPDB.php" and "mysql.php" into _mmServerScripts folder was a working solution (for which I had no need to be helped, thanks, I know how things run). At least for this solution, you need to have created a database binding with DW CS6.

    So when do we get a normal Dreamweaver ? I mean : when will Dreamweaver CC FINALLY behaves like DW CS6 ?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2013 6:49 AM   in reply to Luffy_D_Monkey

    There's more than one month passed...

     

    No answer from Adobe ?

     

    I also see that the uncomplete solution posted on Youtube is still missing the point...

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 27, 2013 2:15 PM   in reply to bgupta16

    I am having the exact same issue.

    Error Code 404:

    Reason 1. No testing server running on the server machine.

    Reason 2. testing server specified for this site does not map to the http://www.my-domain.com/_mmServerScripts/MMHTTPDB.php URL. Verify the URL Prefix maps to the root of the site.

     

    I watched the tutorial but was unable to apply it to my files. I can not find MMHTTPDB.php or mysql.php files anywhere on my computer. I have done a general search, as well as checking each individually installed folder that came with DW. They are nowhere to be found. I have the folder "_mmServerScripts" but it is empty, as another poster had mentioned. How and where do I find the files to put into the folder as I am currently unable to make a connection to MySQL DB. Any and all help is greatly appreciated.

     

    Thank you! --Sharon

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 9, 2013 5:37 AM   in reply to skaycina

    Hi skaycina.

    I'm using Windows 8.

     

    The steps to solve your problem:

    1. Copy both files: "MMHTTPDB.php" and "mysql.php" from your C:\Users\CX41\AppData\Roaming\Adobe\Dreamweaver CC\en_US\Configuration\Connections\Scripts\PHP_MySQL\_mmDBScripts

    2. Paste those files to your C:\xampp\htdocs\lilymewah\_mmServerScripts

     

    Try to do bind the database from Dreamweaver.

    Mine is ok now!

     

    Thank you.

     

    reference: http://www.youtube.com/watch?feature=player_embedded&v=cB2vmNfcq7A

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points