Skip navigation
zigonlightrail
Currently Being Moderated

Reader within Firefox 2x hides base of view behind Windows taskbar?

Jul 17, 2013 7:58 PM

Tags: #firefox #hidden #behind #scroll_bar #adobe_reader_xi #windows_7_taskbar

I currently use Firefox 22, but have had this issue since v21. This computer came with Windows 7 Home Premium in an OEM version associated with the system's vendor, CompaQ / H-P.

 

I have FF set to handle PDF files from external URLs using Adobe Reader XI within Firefox.

 

Whenever it opens a URL for a PDF, the bottom end of the vertical scroll bar, and the part of the page view near it, are hidden under the Windows 7 taskbar. (note the lower-right corner of the image following)

 

snap130717.jpg

 

The hidden-stuff issue can be temporarily fixed by enabling / disabling at least one of the Firefox toolbars, but that would have to be done every ____ time a PDF-file URL is opened.

 

The only other alternative offered to me so far is using FF's intrinsic PDF.js feature (Preview in Firefox), which makes for a far, far fuzzier view of the PDF file than the Reader-in-FF option. I do NOT want to use Reader (or some alternative thereto) in an external window, as it makes for a longer loading time for the PDF, something which takes even longer using PDF.js / Preview.

 

It'd be much easier to solve this once I know the real origin of the problem. Is it Reader, Windows, or Firefox?

 
Replies
  • Currently Being Moderated
    Jul 17, 2013 8:07 PM   in reply to zigonlightrail

    I notice you're running in "Classic" mode. You don't, by chance, have your taskbar set to "Always on top" do you? THat's the only thing I know of that will cause apps to open "behind it"  and it's only an option in Classic mode.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 18, 2013 2:23 PM   in reply to zigonlightrail

    That window interface is "Classic". Right clicking the taskbar and choosing Properties will (or should) allow you to select or unselect to keep the taskbar on top of other windows in Classic mode.

    Parallels DesktopScreenSnapz001.jpg

    With it unselected, apps like Firefox CANNOT "slide under" the taskbar in full screen or when content is larger than the viewport. At any rate, it's NOT a Reader setting that controls this.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 18, 2013 4:39 PM   in reply to zigonlightrail

    If you lock the taskbar in 7, it should have the same effect as keeping it on top in XP.

    Here's the OTHER thing I noticed on further review of your initial post

     

    See this?

    Parallels DesktopScreenSnapz008.jpg

     

    Firefox IS NOT maximized in that view. (this from my WIndows 7 in "Classic mode")

    Here's what it looks like maximized (not just expaned to fill the whole screen)

    Parallels DesktopScreenSnapz007.jpg

    Notice the center switch - it's different when maximized. When FF is Maximized, it CANNOT be moved under the taskbar. Stretched to full screen (but NOT maximized), it can.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 18, 2013 5:04 PM   in reply to zigonlightrail

    Hmmm... it DOESN'T do that on my Win 7 X64 system in Classic mode or Windows 7 theme. Maybe it has to do with the "Classic Shell" you have installed (which incidentally you don't need because Windows can emulate it just the same without any additional software), since I don't have it and CAN'T duplicate this.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points