Skip navigation
mr_erickson
Currently Being Moderated

Extension Builder 2.1 'Building workspace' has encountered a problem

Jul 24, 2013 11:44 PM

Tags: #error #workspace #building #2.1 #extention_builder

Any extension that includes support for CS5, now has a compile error:

 

'Building workspace' has encountered a problem.

Errors occured during the build.

 

Any suggestions? there isn't any detail. I created a test extension that is simply defaults for a Creative Suite Extension with support for CS5. An extension that supports later versions has no error. Interestingly, my other build computer has no problem. Problem just started yesterday...

 
Replies
  • Currently Being Moderated
    Jul 25, 2013 12:02 AM   in reply to mr_erickson

    Are u selecting creative application version as CS5 in the 2nd page of new project wizard or created as a higher version extension project and then modify the minimum target version in Bundle Manifest Editor?

     

    In the latter case, the code generated for CS6/CC will have compile error in CS5 due to Flex upgrade.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 5, 2013 10:38 AM   in reply to mr_erickson

    Hello, Mark, I'm experiencing same issues with CS5 AI host adapter. Have you managed to find some workaround for this maybe?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 5, 2013 12:44 PM   in reply to mr_erickson

    The problem is one has to upgrade to 2.1, either extensions won't work in CC. And creating separate version for CC just because of this is slightly annoying.

     

     

    mr_erickson wrote:

     

    Interestingly, my other build computer has no problem. Problem just started yesterday...

     

    that's interesting, does Extension Builder 2.1 installation work fine for you on another computer? or it was 2.0?

     

    I've looked at the log, here's what it says.  

     

    !MESSAGE Errors running builder 'Adobe Extension Builder' on project 'ha'.

    !STACK 0

    java.lang.ArrayIndexOutOfBoundsException: 3

              at com.adobe.cside.libsinstaller.hostadapter.HostAdapter.getFilePathForA dapter(Unknown Source)

              at com.adobe.cside.libsinstaller.hostadapter.HostAdapter.getExtBuilderLi bInstallerPath(Unknown Source)

              at com.adobe.cside.libsinstaller.hostadapter.HostAdapter.getPluginLocati onInExtBuilder(Unknown Source)

              at com.adobe.cside.project.APEBuilder.checkHostAdapterPlugins(Unknown Source)

              at com.adobe.cside.project.APEBuilder.build(Unknown Source)

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 5, 2013 7:21 PM   in reply to mr_erickson

    This issue is really interesting. Neither dev team nor qe team could regenerate the 2 issues you ran into. I also checked the code in the exception stack, and this exception should have no chance to happen.

     

    So I'm guessing there may be some class conflict in the classpath of your environment. Are you installing the EB2.1 in an existing Flash Builder or on a clean environment? If in the former case have you make sure to remove the previous version of Extension Builder before installation? If not sure about the answer, I would recommand a clean re-install. Uninstall Extension Builder and Flash Builder, delete all the keys and values related to them in the registry, and then run the installer.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 6, 2013 1:42 AM   in reply to xujieadobe

    Already did all this - uninstall, cleanup, install FB separately, install EB2.1, same error, uninstall, cleanup, install into cleaned up environment, so FB 4.6 is installed along with EB2.1 - still the same.

    I've also noted that EB SDK paths should always be added manually, either they are not in the list.

     

    I'm on OS X 10.8.4, so there's no registry. But I've deleted all I found from /Library/Application Support and /Applications

     

    I'm using trial version of Extension Builder 2.1, if it makes any difference

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 7, 2013 11:56 PM   in reply to Evgeny_Trefilov

    Trial version is functionally identical to the licensed version.

     

    On Mac, uninstall could be done through /Applications/Utilities/Adobe Installers/Uninstall Adobe Flash Builder 4.x. After that, make sure /Application/Adobe Flash Builder 4.x folder was cleanly removed.

    Following command:

         system_profiler SPApplicationsDataType | grep Adobe\ Flash\ Builder\ 4

    could also be used to verify Flash Builder has been removed successfully.

     

    One more question is: what do you mean by EB SDK path?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 8, 2013 1:26 PM   in reply to xujieadobe

    When I create new extension from the scratch with the wizard it is not set up correctly - Extension Builder 3.4 SDK is missing, same for 4.5. I have to manually add the paths to Extension Builder SDKs in Flash Builder.

     

    But - I have just uninstalled it all again, cleaned and installed EB2.1 anew with FB4.6 - and it's all set ok and finally works!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 8, 2013 8:51 PM   in reply to Evgeny_Trefilov

    Just realized from Mark's email, have u upgraded your Flash Builder to version 4.7 through Creative Cloud? Flash Builder 4.7 is not compatible with Extension Builder 2.1, that is the reason we embedded Flash Build 4.6 in the installer.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 9, 2013 6:19 AM   in reply to xujieadobe

    no, 4.5 and 4.6 only.

     

    but as I said, it finally solved itself somehow

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 14, 2013 5:23 AM   in reply to Evgeny_Trefilov

    Hi,

     

    We are looking at this issue.

    Evgeny - is this still working for you after the fresh install?

     

    Mark - I assume this is still unresolved at your end?

     

    Best regards,

    Hallgrimur

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2013 4:03 AM   in reply to Hallgrimur Bjornsson

    Yes, working just fine, but I had to uninstall Flash Builder 4.5 first, cleanup both with cleanup tool and manually deleting what's left - especially 'cascaded' folder in projects folder - maybe it was causing issues?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 18, 2014 9:14 AM   in reply to Evgeny_Trefilov

    Just tried creating InDesign CS5 extension with host adapter in EB2.1 - and it's same problem again *sigh*

     

    I have found a workaround though.

     

    copied adapter entries from .mxi, turned off checkbox for Host Adapter, cleaned the project, then manually added back these entries to .mxi - and it compiles now

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 21, 2014 7:54 AM   in reply to Evgeny_Trefilov

    spoke too soon.. while editing.mxi is possible, it doesn't help much, since com.adobe.cshostadapter.IDScriptingEventAdapter is not available unless I include it (pretty obvious). But including it causes same error

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 6, 2014 3:35 AM   in reply to Evgeny_Trefilov

    Hello,

     

    Any news on this?

     

    I have bought Extension Builder 2.1, installed on a clean machine and can not build an Extension for InDesign 5.5 - CC.

     

    I think I need the 3.4 sdk. I have looked into the SDK folder in the Adobe Flash Builder 4.6 folder and can only see, 3.6.0 and 4.6.0.

     

    P.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 6, 2014 7:29 AM   in reply to Pickory

    Hello,

     

    This worked for me on Mac 10.6.8

     

    Installed Extension_Builder_2_1_LS1

    Launched Adobe Flash Builder 4.6 and opened my project

    Quit Adobe Flash Builder 4.6

    Removed the .staged-extension folder from my project folder

    Launched Adobe Flash Builder 4.6 and quit FB

    put the .staged-extension back into my project folder

    Launched Adobe Flash Builder 4.6

     

    P.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 6, 2014 9:10 AM   in reply to mr_erickson

    I'm also getting this error for an extension that supports CS5.5 as a minimum.

    I've done several uninstall-cleanup-reinstall runs and had no joy.

    Is there any new info on a fix / workaround?

     

    Specifically, I get:

     

    java.lang.ArrayIndexOutOfBoundsException: 3

              at com.adobe.cside.libsinstaller.hostadapter.HostAdapter.getFilePathForA dapter(Unknown Source)

              at com.adobe.cside.libsinstaller.hostadapter.HostAdapter.getExtBuilderLi bInstallerPath(Unknown Source)

              at com.adobe.cside.libsinstaller.hostadapter.HostAdapter.getPluginLocati onInExtBuilder(Unknown Source)

              at com.adobe.cside.project.APEBuilder.checkHostAdapterPlugins(Unknown Source)

              at com.adobe.cside.project.APEBuilder.build(Unknown Source)

     

    Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 11, 2014 4:19 AM   in reply to mr_erickson

    The problem for me seems to have stemmed from opening an existing project without first having created a new one.

    Creating a new project from a fresh install sets up some extra bits in the workspace, including the SDKs and unknown tokens which have to be manually added otherwise.

    Now when I build, I still get this error, but on about the 3rd launch attempt it works

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2014 6:23 AM   in reply to mr_erickson

    hello all,

    Running into the same problem,

     

    I had a clean install on a new computer,

    I imported an older project that I have to upgrade and want to be able to compile for 6 and cloud.

     

    I can compile,  for all other version except for CS 5.5. (the one I need)

     

    I had played around with different SDK and host adapter’s setting nothing.

     

    Has anyone found a workable solution to this?.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2014 8:34 PM   in reply to kc2scy

    has any body  found the solution to this?  I got it to work some how and for no reason it stopped I need a solution.. please.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points