Skip navigation
Currently Being Moderated

Native Extensions fail in FlashCC Debugger

Jul 30, 2013 9:51 AM

Tags: #extensions #debugging #native #flashcc

I have a project using Native Extensions. While the project compiles and works fine on an Android device, when debugging I get a "Debugger failed to launch" error.

Removing the native extension references solves the issue, so I assume it's that that causes the debugger crash.

 

This is most regretable as the debugger opens a lot faster and provides better feedback than having to load the project up to a device.

Is anyone working on this bug?

 
Replies
  • Currently Being Moderated
    Jul 30, 2013 1:56 PM   in reply to Peter Strømberg

    I dont think it is a bug, i could not use the vibrate extension because my computer does not have one. I just test it once on my device  then disable it till i finish development.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 30, 2013 8:59 PM   in reply to Peter Strømberg

    Hi Peter,

     

    Could you please provide the exact steps and the OS details. I assume you are using "Debug-> Debug via USB" option to launch debugger on Android Device.

     

    Thanks and Regards,

    Meenakshi

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points