Skip navigation
ray_lee1993
Currently Being Moderated

Adobe Premiere Pro could not find any capable video play modules...

Aug 17, 2013 3:13 PM

Tags: #nvidia #premiere_pro #video_play_modules

When I open Adobe Premiere Pro CC I get this error message:

 

"Adobe Premiere Pro could not find any capable video play modules. Please update your video display drivers and start again."

 

I checked and my NVIDIA GPU is updated

 

I build this computer from new components:

CPU: Intel 3.4 GHz processor (with Intel HD Graphics)
GPU: EVGA NVIDIA GeForce 650Ti BOOST (2GB)\

RAM: 16GB DDR3 1333

 

I tried to make it so that Premiere uses only the NVIDIA Card instead of Intel's but it's not working. This might be key to solve the problem. But I don't know how to do that.

 

P.S. Please don't comment "I have this problem too..." WITHOUT some sort of help. This doesn't help anyone. I noticed this to be a problem with AMD GPU people. BUT help with NVIDIA.

 
Replies
  • Currently Being Moderated
    Aug 17, 2013 6:21 PM   in reply to ray_lee1993

    >only the NVIDIA Card instead of Intel's but it's not working

     

    Every desktop motherboard I have ever heard of will automatically disable the onboard graphics adapter when a card is plugged in

     

    What is your brand/model motherboard?

     

    Below are laptop discussions which MAY help... especially the one about the BIOS

    -http://forums.adobe.com/thread/1001579

    -Use BIOS http://forums.adobe.com/thread/1019004?tstart=0

    -link to why http://forums.adobe.com/message/4685328

    -http://www.anandtech.com/show/4839/mobile-gpu-faceoff-amd-dynamic-swit chable-graphics-vs-nvidia-optimus-technology/2

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 18, 2013 7:12 PM   in reply to ray_lee1993

    I am having the same problem. I am currently unable to use Premiere CC. I am a new CC member and I was able to use Premiere previously, but I don't know which specific version was installed (I've only used it as part of my CC subscription, but it was early.. was that ever using CS6?).

     

    Anyway, Premiere *CRASHES* when this happens. I took a look at it in the debugger just to see what it had to say, but there is nothing obviously relevent (it is apparently just doing some shutdown logic). Here's the call stack just in case someone wants to fix a null pointer exception:

     

    handled exception at 0x01101411 (dvaui.dll) in Adobe Premiere Pro.exe: 0xC0000005: Access violation reading location 0x0000000000000038.

     

    >dvaui.dll!dvaui::ui::UI_Container::DeleteChildren()  + 0x81 bytes
    [Frames below may be incorrect and/or missing, no symbols loaded for dvaui.dll]
    dvaui.dll!dvaui::ui::OS_Window::~OS_Window()  + 0x7e bytes
    dvaui.dll!dvaui::sharedui::DVAAboutDlog::UI_IsChild()  + 0x604 bytes
    dvaui.dll!dvaui::sharedui::DVAAboutDlog::~DVAAboutDlog()  + 0xb5 bytes
    Dialogs.dll!DLG::CloseDialog()  + 0x404 bytes
    Dialogs.dll!DLG::ColorPicker::UI_ColorPickerControlsContainer::UI_Colo rPickerControlsContainer()  + 0x74f80 bytes
    Dialogs.dll!DLG::ColorPicker::UI_ColorPickerControlsContainer::UI_Colo rPickerControlsContainer()  + 0x4dbf bytes
    Dialogs.dll!DLG::ColorPicker::UI_ColorPickerControlsContainer::UI_Colo rPickerControlsContainer()  + 0x5009 bytes
    ntdll.dll!LdrShutdownProcess()  + 0x1d1 bytes
    ntdll.dll!RtlExitUserProcess()  + 0x90 bytes
    msvcr100.dll!_get_pgmptr()  + 0x249 bytes
    Adobe Premiere Pro.exe!00000000004017f0()
    kernel32.dll!BaseThreadInitThunk()  + 0xd bytes
    ntdll.dll!RtlUserThreadStart()  + 0x21 bytes

     

     

    I have been scanning Google and (primarily) these forums for solutions with no success. I've updated my video driver, did the nVidia hack and verified GPUSniffer, logged out of CC, deleted prefs, ran as Administrator, tried Vista and Server compatibility modes, and all permutations of these. Nothing is working. Here is the output of GPUSniffer, for instance:

     

    C:\Program Files\Adobe\Adobe Premiere Pro CC>GPUSniffer.exe

    --- OpenGL Info ---

    Vendor: NVIDIA Corporation

    Renderer: GeForce GTX 560 Ti/PCIe/SSE2

    OpenGL Version: 2.1.2

    GLSL Version: 1.20 NVIDIA via Cg compiler

    Monitors: 2

    Monitor 0 properties -

       Size: (0, 0, 1920, 1080)

       Max texture size: 16384

       Supports non-power of two: 1

       Shaders 444: 1

       Shaders 422: 1

       Shaders 420: 1

    Monitor 1 properties -

       Size: (1920, 0, 1920, 1080)

       Max texture size: 16384

       Supports non-power of two: 1

       Shaders 444: 1

       Shaders 422: 1

       Shaders 420: 1

     

     

    --- GPU Computation Info ---

    Found 1 devices supporting GPU computation.

    CUDA Device 0 -

       Name: GeForce GTX 560 Ti

       Vendor: NVIDIA

       Capability: 2.1

       Driver: 5.05

       Total Video Memory: 1024MB

     

    C:\Program Files\Adobe\Adobe Premiere Pro CC>

     

     

    I am not able to work. This exact machine ran Premiere just fine in the past. I haven't used Premiere since early June.

     

    This is a big problem. The main reason I bought CC was for Premiere, and now I'm locked into it for a year and can't even use the main thing I got it for. Hopefully the devs will soon realize this is not an isolated incident and will fix it ASAP. If it is a system configuration issue of some sort, despite this program working in the past, more logging and information would be tremendously helpful to determine what exactly is going wrong here.

     

    Thanks in advance to anyone who can help with this, I'm really in a bind!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points