Skip navigation
DoctorE99
Currently Being Moderated

Premiere CC to AME -> H.264 nightmare rendering problems with CUDA on rMBP

Aug 26, 2013 5:31 PM

Tags: #black #rendering #crash #h.264 #encoding #mp4 #stall #hang #stops #prores #ame #stalls #blackscreen

I've been struggling for weeks trying to troubleshoot and narrow down my encoding nightmare on my own and I have finally succumbed to getting the forum's or Adobe's Help.

 

Problem:

Rendering a Premiere Pro CC project with via Export Media > Queue to AME in H.264 causes the encode to randomly fail on multiple projects.

I find it quite amazing that this error happens as I surely am not the only one rendering ProRes to H.264 on a new Macbook Pro!

 

Symptom:

Output preview starts to flicker then encoding stops randomly, preview window turns to a black screen or simply stalls while the Elapsed Time keeps rolling, PProheadless crashes in Console, encoding sometimes resumes after several minutes post the crash (but sometimes not) however the final output in such case is garbled before/after the crash. Computer is useable. All other software shutdown. Not using computer during encode. Can reproduce virtually every time.

 

 

Hardware:

Early 2013 Retina Macbook Pro

Processor  2.8 GHz Intel Core i7

Memory  16 GB 1600 MHz DDR3

Graphics  NVIDIA GeForce GT 650M 1024 MB

 

Software:

Premiere 7.0.1 (105)

Adobe Media Encoder 7.0.1.58 (64bit)

Creative Cloud Latest Updates

Cuda 5.5.25 (latest)

GPU Driver: 8.12.47 310.40.00.05f01

OS X 10.8.4 (latest)

 

Project Details:

ProRes 4:2:2 or AVCHD sources

No nested sequences

Video track with image over whole sequence

Video track with text over whole sequence

Video track

Audio track

Sometimes video track with adjustment layer

Standard disolve effects between cuts

4 effects used: denoiser for audio, luma corrector and twice Fast Color Corrector

No third party plugins installed nor used

Sequence is set to Maximum Bit Depth / Max Render Quality / Linear Color

Use Previews off

Encode is set to Maximum Render Quality and always H.264 2pass VBR.

 

Errors in console:

8/27/13 12:38:01.144 AM PProHeadless[1389]: [CL_INVALID_OPERATION] : OpenCL Error : Failed to retrieve device information! Invalid enumerated value!

This is seen at multiple times while starting Premiere (no crash) and while starting the encodes and usually after/during the crash.

 

Crash report:

Process:         PProHeadless [410]

Path:            /Applications/Adobe Premiere Pro CC/Adobe Premiere Pro CC.app/Contents/PProHeadless.app/Contents/MacOS/PProHeadless

Identifier:      PProHeadless

Version:         7.0.1 (7.0.1.105)

Code Type:       X86-64 (Native)

Parent Process:  dynamiclinkmanager [397]

User ID:         501

Date/Time:       2013-08-26 21:12:21.878 +0200

OS Version:      Mac OS X 10.8.4 (12E55)

Report Version:  10

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_CRASH (SIGSEGV)

Exception Codes: 0x0000000000000000, 0x0000000000000000

 

Full Crash report:

http://pastebin.com/a93cNVqk

 

 

Attempts to solve the issue:

Tried encoding without external montior

Tried encoding with source on internal HDD, output internal HDD, source exterbak RAID, output internal HDD

Tried encoding with AME while Premiere is open in the background and without it opened in the background

Uninstalled other software that could mess with the graphics: Colormunki, Parallels.

Software mode is fine on all attempts in AME however encoding takes 2-3x longer. On a $3000 laptop it's not really great.

Encoding directly via Export Media > Export without Queuing to Adobe Media Encoder seems to work fine. I have not tried this too many times because I need to render multiple outputs and doing it without AME means a lot of 'sitting and waiting' to click Export for the next format. This is not an option.

Tried deleting the Media Cache

Completely reinstalled OS X 10.8.4 from scratch with no other software running and tried to export. Same problem.

Performed Apple hardward test. No problems.

 

To Test:

I'm planning on installing Bootcamp so I can test the problem in the Windows version and I could pinpoint it to a hardware problem rather than a software problem.

 

Notes:

Problem happens with CUDA and Open CL modes although in Open CL mode, the whole computer tends to freeze intead of just 'stalling'.

Editing and playback inside Premiere is OK! Even encoding out of Premiere is OK directly but not useful for me as I need to render each project to 5 different H.264 formats.

 

 

I hope you guys or Adobe's Support can find a solution to this problem because I'm really stuck between a rock and a hard place.

I've submitted a bug report but their reply is not very comforting:

but their bug report says "Due to the volume of submissions we receive, responses to inquiries are generally not possible. However, we may contact you if we need clarification on your submission." Nice.

 
Replies
  • Currently Being Moderated
    Aug 26, 2013 11:11 PM   in reply to DoctorE99

    Tough to hear DoctorE99 -- Hopefully someone will spark up an fix or a workaround quickly. You've certainly run far more test then I have ...

     

    Anyone else having simiar issues?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2013 10:26 PM   in reply to bkgarceau

    I posted on another thread but reading through this I think CUDA might be the problem. I have same spec mac as DoctorE99 but running CS6 vers 6.05. I completed a project 2 days ago and was able to render it fine, started a new project was able to get the video material into the project (DSLR files off the canon) closed it down but when returned to open up Prem pro the only workspace panel which would open was the Project bin. I attempted  to reset the workspace but no change. I ended up uninstalling the CS6 creative suite and reinstalling it after using adobe cleaner but there is still no change to how Prem Pro CS6 is working. I recall a few days ago having made the CUDA update to 5.5.25?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2013 11:57 AM   in reply to Bliksem7

    I find CUDA to be very inconsistent and again, who is really to blame? I try to find a CUDA driver that works and then just not upgrade for a while. It just seems like it's untested or just not perfect almost with each release from Nvida. I had just gone ot 5.5.25 and I'm not having an issue with PPro CC, but After Effects warns me that the driver isn't built to work with ray tracing or something in AE... it's not a deal breaker for me, but it just tips the hat on that driver and that its most liekly not ready to be impletemented with the Adobe Suite...

     

    I wish there was a page that listed each Software and the approved/most stable driver you should use for it... not the latest, but the most statble. Otherwise it's a guessing game and lots of luck.

     

    So my only suggestion would be attempted an older driver...

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2013 3:31 PM   in reply to DoctorE99

    Yes I considered your "solution" of just upgrading to Adobe CC but on principal I don't want to have to shell out more money to "fix" the problem. I was able to get an Adobe technician to view my screen in real time. He asked me where Prem Pro was after I opened it and my response was "precisely". The only evidence that Prem Pro is open is that there is the taskbar there with what appears to be fully functional drop down tabs but as far as the panels/workspace goes non-existent! He has "escalated" the matter I'll let you know what occurs next. I have tried using the software mode and there is no change. Like you I have wondered about a hardware proplem but I have checked via Disk Utility and there doesn't appear to be any? The CUDA issue well a) I am not sure how I would revert to previous drivers and b) when I re-installed Prem Pro from disc (that's version 6.0.0.) the only render option it gave me was Software only but that was also greyed out. Prem Pro still did not open up as it should!

    I'll let you know what transpires.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2013 3:16 PM   in reply to DoctorE99

    so much for my problem being "escalated". Never heard from Adobe Technical service again so I re-contacted, was in the queue for 90 minutes before chatting with a rep, who indicated he could resolve my problem, who after looking at the issue indicated that the "team" who deals with this is "offline" and I would need to call back 10 hours later! Ridiculous! So much for 24/7 technical service. Apologies for the whinge. In the mean time I have uninstalled the creative suite, used adobe cleaner and re-installed the Suite from the original disc. All the other products in the creative suite including after effects are opening up appropriately except for Premiere Pro and this would be version 6.0.0?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2013 10:14 PM   in reply to Bliksem7

    I've loaded up CS5.5 and interestingly it appears to open and close just fine! I have a workspace back! Interestingly this has the Renderer as software only, greyed out.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 3, 2013 11:51 AM   in reply to DoctorE99

    I've been having similar problems on Retina MacBookPro and Premiere Pro CC for the last couple of weeks; timeline unresponsive to clicks, random denial of 650m's 'qualification', moving mosaics on the retina display, fatal crashes.

     

    After a total clean install did nothing to improve matters, I thought it might be a hardware problem, but local Apple Store found nothing wrong.  Maybe all these problems only started after updating the CUDA driver to 5.5.25, so I downloaded the previous version (5.0.61) from nVidia.  Remarkable - back to sanity!

     

    Seems to me that 5.0.61 to 5.5.25 indicates a lot of re-written code - have they possibly screwed something up in the process?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 3, 2013 12:10 PM   in reply to tvtycho

    Completely agree tvtycho -- 5.5.25 has been nothing but problems... Sticking to 5.0.61 has been very nice.

     

    It's just hard to tell when to actually upgrade your CUDA, espically since the results can be so fatal.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 3, 2013 12:14 PM   in reply to bkgarceau

    Agreed, bkgarceau, it is hard to know when to upgrade. I've been doing it on an ad hoc basis, whenever I remember to look, and nVidia's updates do seem to come thick and fast, maybe worryingly so.

     

    But in future, I will be adopting the age-old tactic, "if it ain't broken, don't fix it."  ;-)

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 3, 2013 12:53 PM   in reply to tvtycho

    Agreed. Wait and see.

     

    I wish adobe would just create a web page with the latest CUDA builds that are stable in Premiere. Sort of listed by software and OS. Just to give a better idea of what actually works. Especially when the software is so reliant on CUDA.

     

    Though most of the time I try and stick with OpenCL anyway, on my Retina. Even though its "unsupported". I've just found that for what I'm doing, it's just works. Occasionally I do go to Cuda, but if I ever get a hint of trouble I usually swap back. Again, "Ain't broken...".

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 3, 2013 3:31 PM   in reply to DoctorE99

    Well so much for my matter being "escalated"... might as well speak to the wall... a deafening silence!. So took matters into my own hands. I was unable to find a way of uninstalling the CUDA drivers. I discovered you can load the previous version and I loaded 5.0.61 but it didn't make any difference to how Prem Pro behaved. It still didn't load any workspace just loaded the Prem Pro Tab with all the still active drop down menus but no panels to be seen. So I clean erased my hardrive and have re-installed Mac OS 10.8.4, re-installed Creative Suite CS6 and everything seems to be working again. Under System Preferences there is no reference to CUDA drivers. Under Project>Project Settings>General I have the option of MPE OpenCL or MPE Software only. It seems to be working OK for now. Avoiding CUDA like the plague!

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 30, 2013 7:51 AM   in reply to DoctorE99

    Thank you for sharing this. I encounter same issues this week. Last week I got big problems with the After Effects and Ray-Tracing. I needed to update Cuda drivers and finally managed to finnish the rendering in a decent quality. This week didn't start too well. After some hours trying to figure our why Premiere suddendly crashes all the time and found out this issue. Not too happy. Luckily the 'MPE Software only' rendering helped me true without totally lose all the deadlines. Working Cuda-driver would be appreciated.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)