Skip navigation
DuncanGT200
Currently Being Moderated

Importing diacritics

Aug 27, 2013 4:18 AM

Does anyone know why I can't import diacritics (ø, é, î etc) from MS Word files into InDesign CC? There must be a preference for this (a colleague using ID CC can do it) but I can't find it.

 
Replies
  • Currently Being Moderated
    Aug 27, 2013 5:36 AM   in reply to DuncanGT200

    Use file place and place the Word file that way making sure you have a font

    with the proper glyphs.

     

    Otherwise, please define "can't"

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 27, 2013 11:31 AM   in reply to DuncanGT200

    However, when I click the 'import options' radio button the dialogue box I get does not allow me to change these options (whereas a colleague also using ID CC gets the correct dialogue box and can import diacritics). Any ideas?

     

    I thought that your question was going to be about Mac fonts and encoding systems, because typographer's quotes ("curly quotes") dropping to O-with-various-diacritics is a classic MacRoman character drop. That is, your text is probably using an ancient encoding scheme. I'm familiar with the drop, but haven't seen it in years. It's usually easy to fix, but sometimes there's nothing to do but save raw text out of Word and specify the encoding when saving .txt, and then using Import Options when placing the raw text file into InDesign while specifying the same encoding when placing.

     

    But the above quote sticks out as a major problem. Are you trying to tell us that everything in the Import Options dialog is greyed out, or everything in the Formatting section is greyed out? It's supposed to be greyed out when "Remove styles and formatting from text and tables" is selected. Is that what is going on here? Or is the whole dialog greyed out? That would sound like a damaged installation of InDesign, to be honest.

     

    It would be helpful if you could post a screenshot of your Import Options dialog, and if you could tell us if you are working on Mac or WIndows. And a bit more detail here:

    If I cut and paste the same document, it appears with diacritics intact, so there must be something wrong with my import options.

    Do you mean cut from ID and paste into ID, or cut from Word and paste into Word, or something else?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2013 3:02 AM   in reply to DuncanGT200

    Do you save you Word file as DOC or DOCX? I would recommend to use DOCX. I have only problems when I try to place German text (which has ÄÖÜäöüß) as DOCs.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2013 3:21 AM   in reply to DuncanGT200

    You can do the same thing to strip all formatting when place .doc file, on MS doc Import Options: Formatting: check on:Remove Styles and Formatting from Text and Tables

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2013 5:04 AM   in reply to DuncanGT200

    DuncanGT200 wrote:

     

    I was saving them as .txt - I have to, I need to strip out all the formatting - but I had the smae problem with other formats

    That is very important piece of information you left out originally. You aren't placing a Word file, you're placing a plain text file.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2013 5:44 AM   in reply to DuncanGT200

    Plain text, yes, a Word file? No.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2013 2:46 PM   in reply to DuncanGT200

    I somehow missed the rest of this conversation.

     

    For what it's worth, the "allow character substitution" checkbox is dangerous, because if it can't find a decent substitute (e.g. straight double quote for poorly-encoded double open quote), it'll just drop in a question mark. If stuff is dropping when you save out your text file, then of course it won't render in InDesign correctly.

     

    So if you're going to export raw text from Word, by all means scroll through and look for problematic characters marked in red. I often save RTF out first, and then open the RTF in my raw-text editor, because RTF will happily preserve encoding information, so it can tell you in a more-or-less forensic way "Someone distilled a PDF on a Mac and the text was encoded as MacRoman, and then someone else copied out of the PDF and pasted into Word, resulting in encoding system conflicts in my Word file, which are leading to having my typographer's quotes drop out when I place raw text."

     

    On top of that, clipboards on Windows and Mac will handle clipboard data differently. To really diagnose your issue (which is irrelevant because you seem to have more-or-less solved it) I'd download one of those clipboard-inspector things to see what was really going on when I copied and pasted.

     

    The reason that would be useful is that I can kind of read through your posts and intuit that your Word files from which you are copying and pasting are probably a mess. So if you can copy/paste stuff outside of plain vanilla ASCII successfully, but not place it in any format, then probably some codepage conversion is going on in the clipboard.

     

    Lastly: Next time, Duncan, just describe what you're doing with more words. Seriously. Understanding what you're trying to do was challenging because you were placing raw text you'd saved out of Word, not Word files. And in the posts immediately above this one, watching you and Bob talk at cross-purposes was just painful. The screenshot you posted was the raw-text specific import options dialog. The import options dialog you get when placing DOC or DOCX or RTF is different; that's probably what you see on your colleague's screen.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points