Skip navigation
eggi1989
Currently Being Moderated

Hidden Coding appearing in Browser

Aug 28, 2013 3:10 AM

Hi,

 

Im having issues with some hidden coding that I cannot delete. Which is causing an issue moving the menu button down out of alignment.

 

When i use dreamweaver i see the following coding:

 

 

<!--start menu-->

 

<nav>

    <ul>

    <li><a href="index.html" class="current">Home</a></li>

    <li><a href="#">Services</a></li>

    <li><a href="#">Delivering Value</a></li>

    <li><a href="#">Case Studies</a></li>

    <li><a href="#">Contact</a></li>

 

    </ul>

    </nav>

 

<!--end menu-->

 

but when i'm in Live Code view or in the browser I get this coding:

 

<!--start menu-->

 

    </a><nav><a href="http://twitter.com/adaptrisECX" title="Follow us on Twitter" target="new">

    </a><ul><a href="http://twitter.com/adaptrisECX" title="Follow us on Twitter" target="new">

    </a><li><a href="http://twitter.com/adaptrisECX" title="Follow us on Twitter" target="new"></a><a href="index.html" class="current">Home</a></li>

    <li><a href="#">Services</a></li>

    <li><a href="#">Delivering Value</a></li>

    <li><a href="#">Case Studies</a></li>

    <li><a href="#">Contact</a></li>

 

    </ul>

    </nav>

    <!--end menu-->

 

Any ideas? I also tried opening it in Notepad++ to see if i could see the coding there but still no luck.

 

Adam

 
Replies
  • Currently Being Moderated
    Aug 28, 2013 4:29 AM   in reply to eggi1989

    I can only say that you are seeing two different files;  the uploaded file is different from the one you are working on.  The reason I came to this conclusion is because HTML/CSS files are plain text files and there can never be any hidden codes.  In DW the code might be in a different colour which you may not be able to see but it should be there nevertheless.

     

    I suggest try to upload the file again and see if the two identical files show the same codes.

     

    Good luck.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2013 4:37 AM   in reply to eggi1989

    eggi1989 wrote:

     

    but when i'm in Live Code view or in the browser I get this coding:

     

    Live Code view shows the output of dynamic code, such as JavaScript and PHP. It looks as though the Twitter links are being injected by JavaScript. Without seeing your live page, it's impossible to offer any further advice. Post a URL to the page so that others can have a look at it.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2013 10:48 AM   in reply to eggi1989

    Adam, in code view, there is no "hidden coding." It's all there. If you're using a template, some of it may be gray and not editable, but you can always change that in your template.

     

    If you see HTML code popping up in your browser it is usually due to either un-closed tags or tags that are closed twice.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2013 1:50 PM   in reply to mhollis55

    I'm guessing there is some JavaScript that's adding the Twitter links into the page when Live Code is invoked.  Similarly, you would see the same thing when viewing source in your browser.

     

     

     

    Nancy O.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2013 2:40 PM   in reply to Nancy O.

    Yes. Knowing where the page is located so that we can really look at it and see what your problem is would help, too.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)