Skip navigation
Gary Niemeier
Currently Being Moderated

This volume does not support The Trash...

Sep 4, 2013 6:11 PM

Since moving LR4 to Mac OS X 10.8.4, I had run into a problem deleting photos. When using the delete key, I'd get the usual dialogue about "delete from disk" or just "remove it from Lightroom." If I chose the former, an error message would pop up saying "This volume does not support The Trash." I gathered from reading the Lightroom Forums that this problem has been driving a bunch of people crazy, and that it's been around at least since Version 3 of LR, and there doesn't seem to be a 'one-size-fits-all' solution. Is it the OS? Is it Lightroom? What exactly is the culprit?

 

All I can say with certainty is what fixed the problem for me. And it was simple.

 

1. Call up the Info panel of the volume with your photos.

2. Make sure permissions is granted (i.e., "Read & Write")

3. Check 'Ignore ownership of this volume.'

 

Just doing Step 3 fixed the problem.

 

There may well be a deeper issue going on that I'm not understanding, but at this point I'm just happy to report what worked. For me at least, it had to do with the Permissions and Ownership of the Volume. Good to know. I hope this helps folks who encounter this frustrating situation.

 

Gary

 
Replies
  • Currently Being Moderated
    Sep 5, 2013 1:19 AM   in reply to Gary Niemeier

    Oh --

     

    I thought it was normal (I'm not an expert on OSX).

     

    Thanks for the information, I'll give it a try!

     

    thomas

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 3, 2013 7:34 AM   in reply to tlieser

    I just got the following procedure from Adobe, which fixes the problem.  Changes should be made on the INTERNAL hard drive as follows:

     

    1. Macintosh HD>>Library>>Application Support>>Adobe

    2. Right click on "Adobe" folder, choose "Get Info".

    3. In "Sharing and Permissions" section, add your user account if it is not already listed.

    4. Change permissions to "read and write"

    5. Click the gear icon at the bottom and choose "apply to enclosed items."

    6. Close info window

     

    1. Return to finder, click "Go" menu and type "~/Library

    2. Find the "Adobe" folder and repeat steps 2-6 above

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 10, 2013 5:34 AM   in reply to Gary Niemeier

    I have been having the same problem as Gary; tried both the solutions described above and it has made no difference, I still get the message 'This volume does not support Trash'.

    This problem only appeared with LR 5 and it seems to me that it's something Adobe need to fix.

     

    Anyone else got any ideas?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 10, 2013 7:11 AM   in reply to Gary Niemeier

    Hi Gary

     

    I have an external HDD used purely for my photos, not for cloning the system (I have a separate drive for that) so I suspect that the solution you describe would not be appropriate in my case.

     

    Many thanks for replying though. Any other suggestions are welcome though I still think this is Adobe's problem.

     

    Regards

     

    Martin

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 10, 2013 8:35 AM   in reply to Gary Niemeier

    Thanks Gary, I'll maybe try this though I'm not keen on fiddling about in Terminal.

     

    Cheers

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 7, 2014 12:47 PM   in reply to Gary Niemeier

    I had the same problem with LR5 and Mavericks. Images and LR catalogue are on a WD My Book Studio II FW800. I used disk utility to repair the disk and all is well now.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 8, 2014 5:06 AM   in reply to Swizzy

    I came across a workaround on the web in a forum (can't remember which one) and it's simple.

    In the Finder, go to the root level of the external HD which contains your photos; create a new folder, call it anything. Immediately delete the folder.

    Return to LR and you should find that photos delete normally after that.

     

    This seems to reset the permissions problem though you have to repeat this workaround every time you reboot your Mac.

     

    Hope this helps.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)