Skip navigation
hhfrancois
Currently Being Moderated

java.lang.ClassNotFoundException: flex2.compiler.i18n.PropertyTranslationFormat

Sep 9, 2013 2:48 PM

Tags: #java #flex #compile

Hi, I try to compile generated library with java process.

So I use the library flex-compiler-oem.jar

 

And I do something like that :

 

 

lib = new Library();
lib.addComponent(new File(sourcesDir, "ClassAS.as"));
lib.setOutput(new File(swcDir, libraryName));
lib.build(true);

 

but after the message : Loading configuration file E:\flexsdks\3.5.0\frameworks\flex-config.xml

 

I have a beautiful stacktrace

 

Error: java.lang.ClassNotFoundException: flex2.compiler.i18n.PropertyTranslationFormat
          at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
          at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
          at java.security.AccessController.doPrivileged(Native Method)
          at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
          at org.apache.tools.ant.module.bridge.AntBridge$MainClassLoader.findClass(AntBridge.java:647)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
          at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
          at java.lang.Class.forName0(Native Method)
          at java.lang.Class.forName(Class.java:270)
          at flex2.compiler.i18n.I18nUtils.getTranslationFormat(I18nUtils.java:395)
          at flex2.compiler.i18n.Compiler.<init>(Compiler.java:105)
          at flex2.tools.API.getCompilers(API.java:261)
          at flex2.tools.oem.Library.recompile(Library.java:739)
          at flex2.tools.oem.Library.compile(Library.java:1205)
          at flex2.tools.oem.Library.build(Library.java:611)
 

 

The class PropertyTranslationFormat is in classpath in fact, I dont understand, and I found nothing from google

Someone meet this issues ?

 

Thanks

 
Replies
  • Currently Being Moderated
    Sep 9, 2013 3:14 PM   in reply to hhfrancois

    Try using compc.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 9, 2013 3:21 PM   in reply to hhfrancois

    If you use -link–report to generate a link report you can see for the test case that worked where it found the logging resources.  Then check your project settings to make sure those resources are available to your project.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points