Skip navigation
Currently Being Moderated

InDesign Interactive Document Export issue

Sep 10, 2013 4:49 AM

Tags: #interactive_pdfs

Hi,

 

I use InDesign CS5.5 (Win). I am creating a multi page interactive document. I mainly use the text frames and buttons. I have many Bookmarks in the document and buttons are to link the bookmarks.

 

When i start creating the documnet and export to PDF i did not have any issue in the doc. when the document pages increases, after exporting the document, the Acrobat show the message to "Click 'Sign' to file out and sign this form...." but i do not have any forms in the doc.

 

I have the same buttons and the text frame in all the pages. I am not sure what objects Acrobat treats it as form objects.

 

When i start deleting the pages from the acrobat, when it reaches the number of page 7, the highlight "Click Sign to fill..." dissapears.

 

can any one faced this issue? please help why Acrobat treats the document as forms fields if the page number increases more than 7.

 

Please help.

 

Regards

Ramji V K

 
Replies
  • Currently Being Moderated
    Sep 10, 2013 4:57 AM   in reply to Ramjivk

    It's not you, it's Acrobat.

     

    This is a weird "feature" that the Acrobat team created. They decided that any document that has more than a certain number of buttons, must have forms to fill out.

     

    So they decided to make things easier for their users to give them a prompt to fill out the forms. Even though there are NO FORMS! (Sorry about shouting, I can't stand this thing.)

     

    If, you absolutely know that people will never need to fill out a form in your document, you can avoid the message by applying security to the document.

     

    acrobat permissions.png

     

    Set the Changes Allowed to either None or Inserting, deleting and rotating pages. Anything below that is not what you want.

     

    Acrobat won't show the message because it will know that it is not allowed to fill in forms.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 10, 2013 4:58 AM   in reply to Ramjivk

    One more thing. This won't affect how the buttons and bookmarks work. And it has nothing to do with your version of InDesign or the version of Acrobat.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 10, 2013 5:44 AM   in reply to Ramjivk

    No, you have to create a password. But that won't keep people from opening the document. That's a different password.

    --

    Sandee Cohen

    Computer Graphics Trainer

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 10, 2013 5:49 AM   in reply to vectorbabe

    This password just for to restrict printing, editing and other tasks

    permission.jpg

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 24, 2013 11:37 PM   in reply to Ramjivk

    On the page panel select from page 2 to last page, mouse righ click: Override All Master Page Items. Or Ctrl+Shift mouse click on each image.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 25, 2013 6:32 AM   in reply to Ramjivk

    Overriding the master page elements isn't as severe as most people think.

     

    First, when you override all the items, DON'T move or resize them on the document pages.

     

    Then, if you move or resize them on the master page, they will update on the document pages.

     

    You can even change the image on the master page and the new image with appear on the document pages.

     

    AND as long as you don't modify any text on the document pages, you can modify text on the master pages and it will update on the document pages.

     

    This is actually the way XPress works. The only difference is XP doesn't have the option to protect all the master page items before overrides.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 25, 2013 7:56 AM   in reply to Ramjivk

    In InDesign if we override the items from the master page by clicking Ctrl+Shift+Click, the objects will break the link from the master page and comes to the body page.

    So when we update the content or image in the master page, the updates will not happen in the body page as the objects are already override from the master page.

     

    You are wrong.

     

    As long as you don't touch, move, or change the content on the document page, the items will still be governed by the master page items.

     

    Try it on a test document.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 25, 2013 7:59 AM   in reply to Ramjivk

    Bringing a master item to live page doesn't not totally break the link

    with the master. Only the attributes you change on the live page will

    override.

     

    Example: You have a blue rectangle on the master. You bring it to the

    live page and change it to red. On the master you add rounded corners.

    The rounded corners will be applied to the red rectangle on your live page.

     

    If you want to totally detach it from the master, select it and from the

    pages panel menu choose master pages> detach selection from master.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points