Skip navigation
Currently Being Moderated

Packaging error using Xcode 5 simulators

Sep 12, 2013 1:51 AM

I'm attempting to test mobile Air apps against iOS 7 via the Xcode 5 simulators, through Flash Builder 7.  My apps (Flex 4.6+/Air 3.5+) open just fine in the simulators packaged with Xcode 4. However, once I install Xcode 5 GM, I get the following error:

 

"Error occurred while packaging the application:

SDK is missing GPL component /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator. platform/Developer/SDKs/iPhoneSimulator6.1.sdk/../../../../../usr/llvm -gcc-4.2/lib/gcc/"

 

This error is occurring for for any targeted simulator (6.0/6.1/7.0/etc) and any Air version.

 

If I go back to Xcode 4, I don't have any problems up through v6.1 of the simulators.

 

Any thoughts?

 

Thanks

Parks

 

MacBook Pro -- OS X 10.8.4

Flash Builder 7

Flex 4.6+

Air 3.5+

 
Replies
  • Currently Being Moderated
    Sep 12, 2013 7:57 AM   in reply to wxsouth

    Having the same issue here.

     

    "SDK is missing GPL component /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator. platform/Developer/SDKs/iPhoneSimulator7.0.sdk/../../../../../usr/llvm -gcc-4.2/lib/gcc/"

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 14, 2013 2:55 PM   in reply to wxsouth

    Yep, you are not alone:

     

    MacBook Air -- OS X 10.8.5

    Flash Builder 4.7

    Flex 4.6+

    Air 3.8

    XCode 5 GM

     

    Am reinstalling XCode 4 to try and get back to being able to build for the iOS simulator. Presumably will be addressed by update once iOS7/XCode5 go public release?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 18, 2013 3:28 PM   in reply to Geof Brownbridge

    I was hoping that today (ios7 release day) this would be resolved, but it's not.  I downloaded xCode 5 GM and get the same errors.  Now I have to uninstall and downgrade.  I'm not hopeful for a quick update from Adobe either. 

     

    MacBook Retina OS 10.8.5

    FB 4.7

    Air 3.8

     

    To anyone that downgraded. Can I just delete my xCode app and reinstall from a 4.6.3 dmg?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 19, 2013 12:58 PM   in reply to wxsouth

    add me to list, same issue

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 19, 2013 7:21 PM   in reply to wxsouth

    +1 for me too.

     

    It seems like the SDK directory structure has changed with xcode 5. I symlinked to the location that AIR was looking for but then it failed at linking against a 64bit lib.

     

    Hopefully AIR 3.9 fixes this....and fast...

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 19, 2013 8:18 PM   in reply to mus666

    For anyone that needs it, I renamed my xcode.app file to xcode5.app and then installed 4.6.3 from the DMG on developer.apple.com.  Everything is back to normal for writing against ios 6.1 sdk.  If anyone at Adobe even monitors the FB discussions anymore (doubtful), some kind of status on being able to write against ios7 would be great.  Not holding my breath.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 20, 2013 4:29 PM   in reply to unclemick

    Its hard to believe that there is no response from Adobe. Is this not a supported product anymore? Xcode5 and iOS 7 was announced a while ago.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 24, 2013 5:51 PM   in reply to mus666

    I'm not sure, but I think the error is due Apple removed the LLVM-GCC compiler in XCode5. So It's don't gonna work until Adobe start to use the new compiler.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 24, 2013 9:06 PM   in reply to tangamampilia

    Obviously this did not happen overnight. iOS 7 sdk was released over 3 months ago for the expressed purposes of updating anything that requires it. I think adobes commitment to the flash platform and us as developers correlates directly to how long we have to wait for a solution.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 24, 2013 10:23 PM   in reply to unclemick

    I agree.

     

    I hope QT guys release the stable version of their mobile framework soon. I am really fed up with this nonsense.

     

    OR...Adobe needs to open source AIR so we can make the necessary changes ourselves.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 26, 2013 2:10 AM   in reply to mus666

    Have you guys tried the 3.9 beta from the labs. Works fine for me, no problems launching debug configurations in the simulator.

     

    http://labs.adobe.com/downloads/air.html

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 27, 2013 5:43 AM   in reply to michaelarchbold

    I am afraid to pull the trigger on the Xcode 5 download pending in my que.  Do you mind stating which FB version, flex version, Air Version if overlayed, you found success publishing for ios 7 with xcode 5?

     

    thanks in advance

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 27, 2013 6:02 AM   in reply to wxsouth

    AIR SDK 3.9 beta solved the problem for me too.

    I'm using FB 4.7 Build 349722 with overlayed AIR SDK

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 27, 2013 7:12 AM   in reply to michaelarchbold

    Has anyone seen any instability with the beta that we shouldn't use it in production?

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 27, 2013 3:47 PM   in reply to ThruView

    I'm using FB 4.7 (349722), Xcode 5 and the AIR 3.9 Beta with no problems so far. The only error I've had is with using an ANE in debug in the AIR simulator. But doesn't affect device builds so not sure about that one at the moment.     

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 30, 2013 12:16 PM   in reply to michaelarchbold

    I downloaded 3.9 today.  I can compile and debug in the simulator, which is great. However, when compiling for device via usb I get this:

     

    Error occurred while packaging the application:

     

     

    ld: library not found for -lgcc_s.1

    Compilation failed while executing : ld64

     

    Anyone else getting this? 

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points